X-axis move so slow it looks like its not moving - trying to square frame

Hi I have a xtool d1 pro extension table. So far the laser head seems to move the additional length. The problem Im seeing now is: trying to frame my first project after the test “lightburn” project was completed. The project I created is width 305.517mm x 805.663mm. When I hit Frame (the hashed square) after my project is engaged. The laser head begins moving on the x-axis but extremely slow, so slow I thought it wasn’t moving at all until I saw the harness move slightly. I looked on youtube, checked all settings looking for anything that show a speed setting for the x-axis, This is something that just started towards the end of my setup. The initial setup the laser head was traveling the whole bed on all axis at a decent speed. However, I have not been successful to frame properly. Thank you in advance for the help. Lisa

You can change how fast your laser frames in your ‘Move’ tab. Enable it in LightBurn>Window>Move

oh wow! it was set at 0.08 - Thank you! Since I have you. Do you have a pdf file of material settings for my laser xtool d1 pro 20w? And a Suggested settings guide for Lightburn - compatible with my laser machine. So that I can run through to see if all settings look correct? One right off the bat is the Z control settings under device settings

I changed the setting under MOVE and now the laser head move at a highspeed to a hard stop. Nothing in the hardware is stopping movement on the y or x axis. I can move both direction smoothly with my hand.

the hard stop appears to be the middle point of my job;.then the laser stops

Are you using xtool d1 pro’s .lbdev configuration file from their tutorial?

1 Like

We do not provide settings for lasers. We encourage people to use the material test tool to find their perfect settings.

xtool offers settings on their website:

2 Likes

Yes I went to XCS and installed the lbdev configuration file and followed the set up.after that the laser framing worked.

Hi Jen, for xtool d1 pro should enable Gcode clustering in lightburn be enabled under Device settings checking to see if that was a default setting for my laser? Also, still having issues with Material Settings. I am randomly testing different speeds with different power and this method is not working. The material settings sheet you linked is slim pickins’.for the 20w - there must be a better way to know the min and max speed power to burn the grid for more types of materials. Im trying to work on 80lb card stock it continues to burn through when I run the job. When I created a Material test it barely marked on one and burned up the other. Any additional help on this? Thank you. Is there an instructions guide, a pdf file, for lightburn, and are the steps on how to set up the material test generator. main page and sub pages (edit material settings , edit text settings, edit boarder settings)?

Hi Lisa, if you have imported the correct lbdev file for your laser, your device settings will not have gcode clustering enabled. Your device settings should look like this:

Here is a video on how to use the material test tool generator. If you’re experiencing burn-through while testing, you need to lower your power.

Something to consider is that certain colors of card stock may behave differently. Black may laser way better than white, for example.

1 Like

I know I have the lbdev file on my computer It looks like it is installed. Can I open the switch on my xtool d1 pro and hit download to load that file? Is it as simple as that?

To use the .lbdev file, you need to import it into LightBurn.

Go to your Laser tab>Select Devices>Select Import>Select .lbdev file>Click Ok to save>Click on drop down of lasers and select the new imported machine profile from drop down:

looks like I already have it uploaded

You can confirm by comparing your device settings to the image of device settings I posted. If they are correct then you’re good to go, if they aren’t the same as what shows on your computer, please follow the steps above.

Hi Jess,

I am afraid to import this - will it change any functionality of framing movement? - the way the settings are now I was able to find a perfect engrave setting for my oak plywood sign I’m making. power 18.9 and speed 2133 – this is how my settings look before import

When you import a new device profile in LightBurn it is created as a new device, it does not overwrite the other device. You can simply switch back to the old profile if you wish after.

2 Likes