X-Axis Shifting

I purchase a 100w CO2 laser from china with a Ruida 6442G. When I burn rectangles at any speed, the machine works fine. As soon as I try and fill the rectangles it starts shifting on the x-axis even at slow speeds (30 mm/s).

I put a line on the stepper motor shaft and belt gear to see if the shaft was slipping but it was not. The belt seems seemed a little loose so I tightened it and this made no difference and I do not here the belt jumping steps.

Are there any setup things I could have wrong in the controller or on the stepper drive? The x-axis seems to move back and forth nicely when I have the machine off.

Any ideas?

  • List item

so just to clarify, the photo is taken at the same orientation as it is in the machine. it appears to scan from right to left, which would be the X axis and the skewing is in the Y direction from lower right to upper left. whats weird is that the shape is more parallelogram in the that scans are at that slight angle, yet the sides are straight up and down, along with the Y axis. is that correct?

I’m wondering if this is an artifact of the Ruida skewing issue related to “PWM Rising Edge”, specifically along the Y axis.

Configuring a Ruida - LightBurn Software Documentation

The photo got rotated when I posted it. The top of the board is where I had my focus dots and they are along the x axis. The laser was burning in the x axis and the screw is in the x axis. As it burned the axis kept drifting to the right (on the picture down).

I am doing a design of experiment right now by burning in the Y axis direction. Will post results with labels this time. It will take 30 more minutes to burn everything.

I have a feeling that the stepper motor RL(resistance inductance) is not matching the stepper motor driver. I am new to laser machines so this is a challenge for me.

Review the link I sent when you get a chance. This is your most likely culprit.

PY,

That makes total sense when read the link and compare it to the results I have in the y-axis experiment I just did. I am loosing steps in both directions but it is exaggerated in the direction of the engraving. Once I changed the direction it got worse in the Y. See results below that I labeled this time.



Preview

Don’t know if you tried X-axis as well but when I saw your photo for the first time I didn’t realize it was rotated. Normally both X and Y would be on or off for PWM Rising Edge. Try X opposite of what it was in the first photo. Y should probably be set to the same.

PY, I changed the PWM Rising Edge trigger on both axis and it improved the accuracy allot. Then I did another test pattern and you could hear the axis not move for one move and then be off by that distance. It is like the acceleration is too high and the stepper motor cannot move the inertia quick enough. It is like the manufacture did not put the right parameters into the controller. The controller is also setup for 2 lasers and I only have 1.
Thank you for all your help. It has been excellent.
Paul

For the motor skipping reduce idle acceleration or idle speed. Experiment with it until you eliminate any skipping.

You probably want to take a backup of the controller configuration if you haven’t already.

PY,

Thank you again for the support. I have been looking at the settings and comparing them to the machine specs and noticed a disconnect. I also notice Lightburn uses something called JumpOffSpeed in mm/s^2 and then max acceleration. Is the JumpOffSpeed the Ideal Accelleration you mentioned? Based on the specs would you just put the max speed to the spec 1000mm/s? I noted many people are etching at speeds up to 2000mm/s. What’ s your thoughts?


Look under the section for Cut parameters. Should be listed as Idle Move Acceleration and Idle Move Speed.