X Axis Travel Issue

I have an OMTECH 100w laser. Recently the laser started jumping around to random spots while engraving or not lining up properly for an engrave. Anytime this would happen, I’d turn the machine off and when it restarted, it would HOME and then lightly bang on the x axis. I reseated the driver wires and that would temporarily fix the issue for awhile but eventually that stopped working. After some research, i replaced the stepper driver and the motor on the axis. Now, when you try to move the X axis across the bed, it only goes 200mm, but the controller is showing it as 1000mm, the entire length of the bed. I am at a loss on how to correct this. Any ideas?

When it completes boot/home what are the x and y values in the console?

If x or y are 10000, then it’s failed to home on that axes.

:smile_cat:

That sounds like a broken wire in one of the drag chains to or along the gantry. The X axis motor wires are the longest and most subject to breaking, so I’d replace the entire length of all four wires with good-quality silicone insulated wire.

Did you set the DIP switches on the new driver to the same step/rev value as the old driver?

It homes at 0 on both axis. When I move x axis, it says it has gone 1000mm but when I measure the actual distance, it was only 200mm.

After reading forums for hours, I changed the x axis step length to be 1/5 of the original value. That allowed the x axis to travel completely across the bed. However, now my engrave is coming out half the width of my dimesions in LB and wobbly/slanted. Cutting is fine.

Could the wobble/slant be from the motor belt being too tight?

Almost certainly not.

I take it that you did not set the DIP switches to match the step/rev of the previous driver.

If you did not, then set the DIP switches appropriately and set the step length back to its original value.

Upload photos of the new settings and the data plate on the side of the driver. Screenshots of the X and Y axis values (in Edit → Machine Settings → Vendor Settings) will come in handy, as they affect the machine’s behavior during engraving.

Have you resolved the “jumping around to random spots” problem from the start of this thread?

So I checked the checked the DIP switches against the old one and they did match. So then I checked it against the Y axis and there was one switch different. I changed the x axis to match the y axis and now it is back to normal. The sizing is correct and the wavy lines are gone!! Thank you for the help.

Excellent!

It would assist the next person if you’d mention (or show) which switch you changed, because every little bit of knowledge helps.

It was the number 7 switch. With it turned off, the driver was set at 25,000 steps. When it was turned on, it correctly set it at 5,000 steps. Which is also 1/5 of 25,000. This is why I was able to correct my x axis by adjusting the machine settings. I changed the machine settings back to the original number as well.

That makes sense: vive times that makes the steps way too small!