X-carve 1000mm W/ Jtech 7w laser wont go 0,0 Making me Crazy

After homing and I click the Go To Origin button and my laser goes to aprox x=7 and y=0 (guessing) But if i “get Position” it reads x=0 y=0. and it is clearly not. If I manually put the laser at physical x=0 y=0 it is in the negative.
How can I get the laser to zero at x-carve 0,0?
heres what I got:
Grbl 1.1g
$0=10
$1=255
$2=0
$3=251
$4=0
$5=0
$6=0
$10=0
$11=0.020
$12=0.002
$13=0
$20=0
$21=1
$22=1
$23=3
$24=25.000
$25=750.000
$26=250
$27=1.000
$30=1000
$31=0
$32=1
$100=40.000
$101=40.000
$102=188.976
$110=8000.000
$111=8000.000
$112=500.000
$120=500.000
$121=500.000
$122=50.000
$130=750.000
$131=750.000
$132=100.000
$#
[G54:-679.404,-709.320,-43.222]
[G55:0.000,0.000,0.000]
[G56:0.000,0.000,0.000]
[G57:0.000,0.000,0.000]
[G58:0.000,0.000,0.000]
[G59:0.000,0.000,0.000]
[G28:0.000,0.000,0.000]
[G30:0.000,0.000,0.000]
[G92:0.000,0.000,0.000]
[TLO:0.000]
[PRB:0.000,0.000,0.000:0]

i Have also tried the Set Origin button, nothing seems to help

That’s the issue - The offset should be X-750 and Y-750 for the size of your laser. Type the following into the console:

G10 L2 P1 X-750 Y-750

Everything else looks correct. You might want to add that offset line to any macro you have for enabling laser mode. That will put the origin front-left instead of rear-right.

YES!!! THANK YOU!!!
That did change the but not quite on 0,0
How can I make the origin exact 0,0 on the physical work surface?

Physically move your limit switches, or adjust the -750’s above to whatever is needed.

Thank you. Now If i tell it “Go to Origin” it errors
Starting stream
Stream completed in 0:00
ALARM:1
[MSG:Reset to continue]

and says “busy” status and I have to power off controller to reset

image
If i hit the “move to position”
it does go the correct direction but the center of the spindle goes to 100,100
I have tried to use the laser offset function in settings but no change.
The picture reflects the values when my laser is on 100,100
how to I get this offset?

From GRBL docs:

“ALARM:1” : _(“Hard limit triggered. Machine position is likely lost due to sudden and immediate halt. Re-homing is highly recommended.”),

For the offset, type $# in the console again, and post the results, and check that $10 is 0, not 1.

image

When you click ‘Go’, all it does is send G0 X100 Y100 (or whatever number you have entered there). When you click Get Position it’s sending a ? and then interpreting back the numbers.

That’s it - there’s no magic. Everything else is happening on the controller itself, based on settings in the controller, like workspace offsets.

Thanks. So If i have an drawing of a square that i wish to burn on the software work space and i set the drawing on the 100,100, will the LB workspace be the same on the physical xcarve 100,100 and will the drawing and burn be in the same place?
I want to get away from having to draw with a pencil the center of my work then guess where the drawing center is and hope that I all lines up. I’ve had the laser for a while and that’s how I’ve been doing it.
It seems that there should be a more exact way of doing this, and thus me exploring and asking.
You have helped me tremendously so far.
I think I now need to learn how to offset the laser from the center of the spindle. The steps I thought logical, i.e. “laser Pointer Offset” would adjust this, but it does nothing there is no change. How would you offset this?

Laser Pointer Offset is for people with a red-dot pointer that doesn’t point in the same place as the laser itself. I don’t have a means of offsetting everything by a fixed amount, though you could shift the G10 L2 P1 command by the difference easily enough.

Thanks… I am not sure what those commands are or what they do.
I havent picked up the gcode thing yet sorry for being rookie
so:
G10 is ???
L2 is???
P1 is ???
would my offest adjustment for these be 750 plus the offset X? and 750 Plus the offset Y? or the opposite?

G10 L2 P1 is the command - it sets the workspace offset to what follows.
If you enter G10 L2 P1 X-750 Y-750 if offsets your X & Y origin by -750 mm each, so the 0,0 point of the machine is now front-left instead of rear-right.

If your laser is mounted to the front of the spindle, you could reduce the Y offset from -750 to something like -700 instead, offsetting it toward the rear by 50 mm. (I don’t know how far off the laser is from the spindle center)

YES YES YES
I did
G10 L2 P1 X-746.8 Y-688.7

FIXED!!! it was just that far outta my brain…THANK YOU OZ

Haha man you’re not the only rookie, I just figured that out last week myself, it took me 3 months to figure this all out :joy: so don’t feel bad or silly for asking, because OZ and the rest of LB team help me out a LOT!! The fact they’re doing this just shows, we got a awesome software, forum, and team to work with, grow with, and learn from!!

Agreed. Thank you Oz and LB team great support.
Now I can get to work…lol

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.