X-Carve Origin issues

I need some help with setting up my new 7W JTech laser on my X-Carve. The issue that I seem to be having is that when my unit tries to move to the absolute origin, it moves to the front left, but it continues to to keep trying to run past my limits every time. I really do not want to end up with bad motors, belts, and limit switches.

Here is a copy of my $$ Code:
I also tried to switch to a positive workspace by adding G10 L2 P1 X-1000 Y-1000

Did I do something wrong?


I also have the X Carve and was having trouble with settings. I know the G10 L2 P1 X-750 Y-750 did not work for me either and the maximum cutting area is 750mm X 750mm so the 1000 would not work and could be causing problems. For your $$ settings yours look the same as mine, On the main page under “Start From” I use current position and just manually move to the center of the area of engraving, and under “Job Origin” I use “CENTER”. I hope that helps some.

If you have the 1000mm XCarve, that should absolutely work, because the 750mm limit is set in the firmware. When the machine homes, it should be at the rear-right, and that offset shifts the origin to the front left. You also have to set $10=0 so the machine is reporting its position relative to that user origin, not relative to the machine origin.

For future reference, this doc covers the setup of these systems in detail. https://lightburnsoftware.github.io/NewDocs/CommonGrblSetups.html

I was using this same method of not using the absolute origin. I like it better because it is much easier to set up the workpiece. However, after one of my jobs the laser completed the job and attempted to return to its absolute origin and proceeded to crash into my limit switches. Is there an option to tell the laser where to go after completing the job?

Rick and OZ, thanks for the reply. I have read all of the forums over and over and over again. YouTube videos, etc. Although I plug in all of the code mentioned above, this keeps happening. When I manually move my laser to the front left limits and click “Get Position” I get

It seems to me that if I align to the front left, my coordinates should be closer to zero. Is this right? I have the setup in inches if that makes any difference?

Did you home the machine? You have to do that first. Your “connect to LightBurn” cycle should be home the machine, do the offset macro. If the last thing you used it for was lasering, you don’t have to do the macro stuff again, but you always have to home it.

I figured that this would have to happen. I just don’t know how to run a home cycle. When I click the home button, nothing happens

Brandon i am running the same machine and laser you are try changing the $22=0 to $22=1 and see if you can home it.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.