X not homing to limit switch

Before connecting to my PC, the machine would move along X and Y fine, though limited in range due to the settings and home to the X and Y limit switches. When I hooked it up to the PC and edited the range and jogged the laser around with Lightburn I tried to home it, but X stopped 100mm away from the limit switch.

Limit switches are turned on in the device settings.


Did you back up your previous settings before making the changes?

No… I didn’t expect this to happen. I guess tomorrow I need to factory reset the machine.

Ouch! And beware the factory reset, sometimes that can be even worse. Look around at some of the DIY builds with your controller. If it’s a Ruida, Matt did a DIY build and put the basic settings in his video. If it’s a 6445G, I have a copy of one of my Vendor Settings on my Google Mod Page.

I figured out how to fix it. I took the belt off of the motor and moved the laser head to zero. Now it works like a charm.

Crisis averted.

So where is your laser picking up it’s homing signal from? It sounds like it’s not using the homing switches at all if simply moving the head without the belt fixed the problem.

I am just in the beginning of the electronics portion of the Y-1200 build. I realized that the Y pully was actually just loose enough to throw it off a bit so that it wouldn’t zero to the limit switches. All fixed now, though.

My Z axis motor is running pretty hot, though, so I will need to figure that out tomorrow. Probably just the stepper driver settings.

If all is well there, I will start the wiring for my laser tube.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.