XTool D1 doesn't respond

I was using my XTool D1 on their own software and it was working fine. Since I have been using LightBurn on my AtomStack and it was running great, I loaded LightBurn on my laptop and tried running my D1 off of it. I imported the the D1 file into the machine but the machine doesn’t respond at all. It shows up as a choice on the correct comm port. If I unplug the usb cable the laptop gives me an auditory alert, so it sees the machine. If I turn the machine off the same thing. Any idea what I am doing wrong?

It sounds like LightBurn is up and running on your Laptop as expected.

With everything on, powered up and running; select a different COM port in the Laser Window and wait a few seconds. You will see a message in the Console window when it connects. If it doesn’t connect, the next step is likely installing the CH340 driver.

I did. What’s really upsetting is that I got a different Laptop but I didn’t use the xtool software, I just loaded Lightburn and ran the driver. Still nothing

Have you updated the firmware on the D1? You need to be on fairly recent firmware for GRBL functionality to be available.

1 Like

I’ve tried all the methods for upgrading firmware. None worked. I remember some posting on Facebook about turning off a switch on the card and doing it. I think I need to find it.

You can’t update from Laserbox on Windows?

Did you reference this post when looking at the ways of upgrading?

How to upgrade the xTool D1 firmware – xtool

What happens when you attempt to upgrade?

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.