XTool D1 Frames OK, but then burns skewed to the left (around 1 CM)

I’ve had my XTool D1 for a few weeks, and want to graduate to LightBurn from their beginners software (LaserBox). I’ve watched quite a few tutorials and have been doing very well with setting up projects, adding in graphics, etc. But I’ve yet to get Lightburn to burn them where I want.

I’ve been making tumblers using designs we made and generated as .JPGs and finally gave up on LightBurn and made them using Laserbox. Once we finally got everything set up and laid out like the youtube videos and user manual said, it would burn someplace totally different from where the faming showed.

I also wanted to add names on the lids, and LightBurns text text functions were perfect. I figured that would be a much simpler learning experience than using the rotary deck. After I had it created (just a simple name text), I changed the Start From: to “Current Position” and set the Job Origin to center top. I then used the Move tab, Fired the laser at 3.75% and used the jog arrows to move the laser until it was exactly in the position where we wanted to top center to be. I clicked Frame button and it moved exactly where we wanted to have the text. When I clicked Start, it burned it about 1 CM off to the left. I’ve tried every combination of origin settings I’ve seen in online tutorials, etc. and I just can’t get it to start where it’s supposed to, and even when I make a guess at where it should be offset to correct for that, it still goes someplace wrong.

I’m running version 1.1.03 of LightBurn. I downloaded the xTool settings and used them when I set up the device in LightBurn. I’ve upgraded the XTool’s firmware. I’m running on a Window’s 10 64bit machine which is current with updates. And I’m connecting using the USB cable.

Are there any suggestions or tutorials that anyone can point me to to figure out why this is happening?

Thank you in advance.

Rene

Can you upload a screenshot of Edit->Device Settings? Also, do you use the crosshairs on the D1 or just the primary laser light to do your framing?

I just went into the settings, and the Enable Pointer Offset is turned on, and it is set to move x -16mm. I use the laser point, not the cross hairs. I’ll turn that off and see if that fixes it.

Hopefully that fixes it. If it does, I still think that’s bad because “Frame” should show where the burn is going to happen, right? So if it’s going to offset -16mm when it burns, it should also offset -16mm when it shows the framing, IMHO. That would have jumped out at me if the framing had offset.

If that doesn’t do it, I’ll post a screen shot of the settings.

Thanks for the pointer.

Rene

This likely will address it. Or should fix at least one problem as there may be more than one.

The way this is intended to work with D1 is that you frame with the crosshairs, then based on the offset the primary laser will cut within the frame. So it would work as intended. The reason it’s not working now is because you’re using the primary laser for this. So when the offset adjustment is applied the laser moves -16mm to the left from when you did your framing.

This would actually break the purpose of the offset. The reason this offset exists is to accommodate for the difference between the cutting laser and the guiding laser used when framing. This is common on CO2 lasers where the cutting laser cannot be used to frame. There can be an additional pointer laser offset from the primary that you would use to frame, similar to how the D1 crosshair is offset from the primary cutting laser.

Thanks for the explanation. Now I have to figure out how to turn on the crosshairs. LOL. The fire button is right there in my face, hahaha.

There’s no reason to use the crosshairs if you’re comfortable using the primary laser for focus. Having said that, I didn’t think there was a way to turn off the crosshairs actually but let the forum know if you sort it out.

So I think I figured it out. When I was playing with placements using LaserBox, there is an option to either use the crosshairs or a laser point. I had changed that to laser point. EVIDENTLY, when you do that, it turns off the crosshairs permanently in the controller. I went back into LaserBox and changed it to crosshairs and they came back and stayed on after shutting off the XTool and turning it back on, as well as going between LightBurn and LaserBox.

I did a test using the crosshairs and it worked as expected. I only did an eyeball set up on scrap and it looks like I may need to adjust the offset a little, but I’ll know how to do that the next time I do a serious test.

So thanks for the help finding that setting and in understanding what was happening.

Rene

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.