xTool D1 image burns all black

Hello all, new to the Laser engraving community.
I have a problem with the D1 laser engraving an image. If I import a PNG image, lightburn shows the image fine and how I would like it to engrave. However when it starts the job, where detail and white space (no image color) is supposed to be it burns the whole image as black. No detail, no white area…Nothing. It just looks like the outline of the image with fill in for all of the image. I am using GreyScale for the image, should I be using something else?

This is the image I am using. It burns the outline just fine. If I use the software that came with the D1, it works fine.

Can you confirm the following:

  1. You’ve updated to the latest firmware for your laser?
  2. What device type was configured for the laser? Check this by clicking the Devices button.
1 Like

The firmware is the latest according to xTool. That was the first thing I did when I got the laser and so it would work with LightBurn. I can recheck to be sure, but I think I’m good on that part.
The device type I will have to check when I get a change. I will answer you back when I do.


It’s possible that it’s set to GRBL-M3. If so, switch to GRBL and retest.

If that doesn’t resolve it can you upload a sample .lbrn file here that shows the problem?

Just looked at the devices. Its set for GRBL and not GRBL-M3.

Post a known “bad” .lbrn file where this behavior is occurring please.

1 Like

fishing coaster.lbrn2 (226.8 KB)

Okay I see the problem. Nothing with your device setup. What’s going on is related to the fact that this is an image and you’ve chosen to burn this using grayscale image mode.

For diode lasers grayscale will take into account both the Max power value as well as the Min power value. LightBurn will actually assign a power value relative to the darkness of the gray in proportion to the min/max power range.

In your cut settings you had Max Power at 80% and Min Power at 40%.

Because Min was at 40% even the lightest gray, in this case white, takes on 40% power. This is what’s causing the whole image to fill dark.

Here’s the preview with Min set to 0%:

OK, I thought that was part of the issue but wasn’t sure. So should I use 0% for the min power or use a different image mode other than GreyScale?

Yes. Either of those approaches would remedy the situation. The choice is purely about the specific look you want to achieve.

And there’s nothing wrong with setting a non-zero min power but you just need to understand the potential impact it will have. Again, all depending on your needs and the look you’re going for.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.