xTool D1 Monterey OS problem sending data to the laser - machine may be busy or paused

I get the following message when attempting to connect ligtburn to my xTool d1. I am able to run xtool software and I have downloaded the CH340 MAC OS driver, all without success.

There was a problem sending data to the laser.

The machine may be busy or paused.

I was able to run lightburn with xTool last May, but now 6 months later nothing works

I’m going to move this to your own thread in the xTool Group.
May I ask which version of Monterey your mac is running?

In LightBurn, in the Laser window, Click the bottom middle button and screen-shot that. It’s likely the port is live and working and that it’s just been misplaced by a system update. You can try each of those options one at a time, or we’ll guess with you! :slight_smile:

There are a few other things it could be, but this is swift and likely.

I am using Monterey ver. 12.6. Yesterday I loaded and replaced v1.5 with lightburn v1.4 and for a short session everything worked, however where shutdown and restarted it was the same problem loading data as with v1.5.

Also note that I m unable to install this file as there was …“no application to open…”

Problem not solved… The connection problem may be due to the serial port driver. Monterey OS has a driver built in. I installed several of the CH340…c drivers before I found that Monterey OS does not require more. I believe there may be a conflict between the Mac supplied driver and the CH340 … drivers I installed

I have the Monterey OS 12.6

Open LightBurn and in the Laser window press the bottom middle button.
Screen capture the part of the window that shows which ports that are available to LightBurn.
2022-10-24_16-55-41 which com port (laser window)

If XCS is running in the background, the USB port will be allocated and LightBurn may not have access.

I’m going to remove the solution tag and roll your deleted post back to what you had written.

I’m not quite certain which versions of LightBurn, xTool firmware or XCS that you’re using. Quite a few folks are up and running with xTool. We should be able to get some progress here.

Hi that did not help - still not connecting. Xtool support asked if I was using the "xTool-D1-V2.ibdev. I replied that I could not import it into Lightburn (file was greyed out). Should I try to “import perks”?

I’m going to download it and attempt a drag-and-drop into LightBurn.

I’ve installed the xTool D1 Pro device profile (V3) but not the V2 profile.

Confirmed, I dragged the xTool D1 v2 LightBurn device profile from my downloads folder into the workspace and it is now set up for that device.

Thank you for your advice. I did as you suggested and LB responded, “perks are now installed and working”. It did not solve the problem however! I still get the message that LB cannot send data to xTool

It’s likely that LightBurn hasn’t found the right port.
Are you connected with a USB cable?
We may be able to see the port where the xTool is waiting for you when the following information is available:

If other com ports aren’t readily obvious or available, we may need to look for an application that is open and claiming the port.

Usually only comport shows in the laser window. Over the past few days trying it has nmoved from “…20” to “…30 and …40”. It does not seem to matter and xtool works regardless of port assignment.

I now have the xTool perfs installed ( they may have been before) I also have installed several versions of “CH34…” drivers. nothing seems to be the issue. Please note: Once three days ago
LB did connect and I ran a project file. But after shutdown then later restarted the connection problem returned. Anyone have a clue?

Dave (Captain Lewis)


I’m new to LightBurn. I running on an a MacPro and lately I’m back and forth between the latest version of Big Sur and the latest version of Monterey, I have had to back down to Catalina to be able to learn how to use Lightburn. It appears to me that there is a driver compatibility problem when running under both Big Sur and Monterey.

The symptoms I have observed are as follows. Once the driver has been installed and the Mac rebooted, Lightburn shows a list of serial ports which includes 2 FTDI driver ports which have been there for ages as part of my home automation setup. Also in the list are several more ports which all appear to have resulted from the Lightburn driver installation. Lightburn is able to connect to my Laserstorm S10 when I choose one of those ports. However if I close Lightburn then relaunch it, those ports are all missing from the list after the relaunch and Lightburn will attempt to contact the laser on one of the FTDI ports which are already opened and in use by home automation software. Lightburn in fact writes data to one of those ports disrupting the automation package until I close Lightburn again. In order to get Lightburn to talk to the laser again, I have to reinstall the Lightburn serial driver then reboot.

Since backing down to Catalina, I have been able to use Lightburn all afternoon and do some experimenting with the laser. I cannot however continue to run Catalina just for Lightburn. My Mac runs 24/7 doing various things and I need to be running at least Big Sur on a regular basis. Is there any chance there might a newer version of the serial driver V1.5 which would be more compatible with the newer MACOS versions?


The problem is, "Lightburn cannot connect to the laser - “USB port may be busy or occupied ”. Last time I was using XCS before going the Lightburn, I then encountered this USB port message. I bought another MacBook computer and purposely I did NOT load XCS onto it. However, I still received the message about the USB port being “busy ”.

It was suggested to me via Lightburn support, that the XCS did not release the USB port after use. But since attempting to use LB on the new computer where I had not loaded, for used, XCS, that seemed to be unlikely. My only conclusion its that the xTool firmware is holding the port.

On the former computer (also, a MacBook Pro) I have been using XCS successfully for some time and had not problem connecting to the USB port.

Note, that I have loaded the CH340 drivers as was suggested.

Do you hav any advice to give me, Its it possibly a firmware issue of my xTool?

I just reviewed the support desk email.

Let’s just focus on the new computer for now.
Which Mac OS operating system and which version?
I just want to know if you’ve made the jump to Ventura 13.02 yet

After a couple of Mac OS driver installs, I have a hunch that the driver wasn’t the right one for the OS version or wasn’t granted permission. When I hear back from you, I’ll be sure to link the right one.


Here is what I found.

MacOS is Ventura
Above “PAUSE” shows “Ready”No unusual message in the Console

Only one Com port showing, cu.serial - 1440

With laser plugged in, the "Mac > System Report > USB” produced the (attached) list. See the many items attached via USB.

Also note that on this Mac I have many devices plugged in (monitor, keyboard, mouse, etc.) and this may be the problem with this Mac.

Please note that the xTool uses USB2 and I am plugging the xTool into the USBC port (via adapter) on the Mac.

System USB report.png

Thank you for providing this diagnostic procedure.


This doesn’t look like the xTool serial ports I’ve seen.

I do not see an attached list but I am looking forward to it.

I used the Hyper Drive thunderbolt USBc hub for Macbook pro ( for the USBc to USBa)
I used the driver linked here:
Just click the wide Bright-Blue button with the cloud in it.

It’s Bud again. I have had this issue with my PC. I have tried all suggestions but still cannot get anything to process to the laser using lightburn from my X Tool Pro laser. However, I can lay out something on XCS and it will process. I had a simple square and it cut and engraved fine through XCS. Tried same thing with Lihgtburn and still get the same message. Something to the effect of “Cannot send to laser. It may be busy or paused”. I reloaded Windows, XCS and Lightburn. I did try to load a saved file with a lbrn extension. It said didn’t recognize extension. I don’t know if this is part of the problem. I tried to delete those files but it did nothing when i hit the delete button. Then went file list to delete but it didn’t show them. I am OUT of ideas. I am more than willing to wipe out everything I have and start all over again if that is possible. HELP please.