Xtool D1 - Pattern offset between separate runs

Xtool D1 Win 10

I am ablating mask material from a piece of double clad FR4 to make a very small pcb (~2 X 4 mm). I have to “synchronize” the top and bottom pads and perform a cut. I have yet to fully succeed because the pattern is shifting between separate runs. I have the patterns on separate layers in Lightburn.

I have never had it go back to the proper locations after the skewing occurs so it could be that the laser is not returning to the same origin location.

I have tightened the belts but this did not help.

In the enclosed photo you will see a misalignment between two rectangular patterns, almost 4 mm in X and 0.2 mm in Y.


Can you describe the workflow? Are you running one layer at a time, doing something, and then running another layer?

In the photo case, there was noting done other than the auto return to origin between cuts/layers.

How much time was there between runs? One possibility is that there is a timeout after which steppers will power down. Under certain conditions things could shift when the power down occurs and powers back up. I’m not sure how long this is for the D1. Check $1 in machine settings.

If not timing out it’s possible you’re losing steps just in rapid moves between layers. Perhaps try disabling “Return to finish position” in Device Settings. This will leave the laser on the last spot after the job is completed.

It is very odd that the Y shift seems to be exactly at the same interval as the normal Y cuts.

Time between runs is less than a minute. Max velocity is 100 mm/sec from start position to 20 mm/sec during cuts.

I will try disabling Return to Finish Position"


Machine settings: I get a reply of 1 for $1. Is this one second, one minute? There seems to be very little resistance to a gentle push on the laser head, looks like the shutdown occurs pretty soon.

One millisecond. So basically it’s immediately off.

Check for anything that might be overtightened. Basically anything that might be overtensioned/sprung that could result in shifting during power off/on.

There are others having missing steps during rapid moves so it’s possible this is a result of that.

The test of running without returning to finish will tell you. If you still have an issue then it’s likely due to something mechanical. If you don’t then it’s likely that you’re losing steps during the rapid moves.

1 Like

I just saw another post about this problem. He fixed it by commanding a go to origin after the auto return. This won’t fix any “missing steps” due to power off. Is there any info on how long you can leave the motors powered up without motion? I’ve worked on systems that purposely locked the motors after motion but I’m sure they were duty rated continuous. Anybody know anything about the motors (Manuf/Model no.)?

Basically it’s 0-255 (ms). 255 is “always leave powered on”. Unfortunately I don’t believe any of these settings are adjustable in D1.

Not sure how this would work.

I’m not familiar myself.

1 Like

Both differences negative ? I had something similar. Laser lost steps on starting the second run. Reducing max accelaration solved the problem. .

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.