XTool D1 Pro 10W/40W

I was using my 10W module yesterday just fine. Switched to my 40W module and now it won’t even work. I have double checked everything. It has power to the machine. I’m at a loss. Any help would be greatly appreciated and welcomed.

Are you using the same power supply?

You don’t give us much to work with :face_with_spiral_eyes:


I believe the 40w head may come with a different power supply, as that head uses much more power than the stock anemic power supply can deliver.


+1 for the PSU issue.

At least my D1 Pro with 20W blue and 2W IR both came with the same cord-brick 150W PSU to be used with both heads.
AFAIK the 10W & 5W share the same ~80W PSU, and the 40W has its own ~300W PSU.

Even though I wouldn’t recommend using it to actually laser anything, XCS can and should be used for troubleshooting.


I used the power supply for the 40W.

No, I used the 40W power supply.

If I was using XCS, that would help.


Strange, has that combination worked before?

But You do have to use XCS for updating the firmware, adjusting the flame sensor etc. or have You actually found a workaround?
If so, I’d like to hear about it.
As would a lot of other xTool Pro users as well I assume.

I for one wouldn’t dream of suggesting anyone to actually use XCS for lasering since i dislike that POS (Piece Of “Software” :wink: ) with a passion.


Since xTool controller doesn’t quite follow standard grbl, the easiest troubleshooting method is always to do some trivial test with it.
If the test is succesful, it’s just a matter of tinkering with LB parameters.
If the test is unsuccesful with XCS, there’s some fundamental flaw somewhere in the hardware.


I am not to fond of the software either. I have done all the updates through XCS and still no luck. I think the motherboard to my 40W module went out.

If you have a voltmeter (and can drive it) you can easily check the output of the controller to the laser module. There is usually only a ground, pwm and V+ supply…

If all of these are good, that leaves the module itself…


My son in law has one. I can have him check it. Thanks for the info.

I figured out what was wrong. It was human error on my part. Just a simple update was all it was.

This topic was automatically closed after 30 days. New replies are no longer allowed.