xTool D1 Pro 20 watt

I recently purchased my xTool D1 Pro 20 watt laser engraver. I have the whole thing setup and ready to go. I tried using the XCS proprietary software for XTool or XTool Creative Space. Every time I try to engrave a maple leaf, I frame it and my laser draws a frame approximately 3mm wide by 100mm long. I’ve tried using lightburn and I keep getting errors saying the laser is busy or not connected.

Since xTool is not listed in the available engravers. I’ve tried to setup a manual connection. I’ve selected GRBL and USB COM4. But nothing seems to work. I have the CS340 driver installed and recently installed the CS341 driver. I have big hopes of many projects for this engraver but I can’t do anything if I can’t get it to work.

Any help would be appreciated


A professional Santa in his workshop

I suggest you read the xTool D1 Pro with LightBurn guide and watch the LightBurn youtube video about the D1. The machines are fairly similar.

Use LightBurn to Operate xTool D1 Pro – xTool

xTool D1 Laser Engraver LightBurn Set Up & First Project - YouTube

I watched the video and downloaded the file and now lightburn recognizes the engraver. Now when I try to engrave it still engraves a vertical line and usually burns through. I have yet to be able to see a complete picture engraved in wood. Is it possible I got a defective engraver? Why does what I see on my monitor not come out on the material I’m engraving?

Possible but unlikely.

Can you take a full screenshot of LightBurn with your design showing?

Also, have you made any successful burns with XCS?

I found a number of assembly errors with my D1 Pro delivered two days ago:
(1) The belt for X axis motion had tension, but the belt was not in a slot on the laser head trolley. When I framed I got Y movement but no X movement.
(2) The wire feeding the +X axis limit switch was routed across the X axis bridge, but the connector was not plugged in at all.
(3) Seems like you found out that with a new D1 Pro, you must first use the xTool Creative Space tool, which updates the firmware. Stick with using a USB connection while doing this.
(4) I did finally get the WiFi connection to work with Creative Space, but there isn’t a way go change the SSID and password once you do. So make sure you get it right (I wanted to use WiFi with two different routers, but no joy with that so far)
(5) I have not been able to get LightBurn to work with WiFi at all–It takes the IP address (in a very non-standard way), but never connects. Console reports “Waiting for connection”.

I’m now watching my maple leaf being engraved. My X axis belt was too snug. Even though I have an arrow on my screen. I guess the leaf was still in the memory. It looks great. I will need to tweak the settings to eliminate the lines on the engraving.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.