Xtool D1 pro 20W running Lightburn has started scoring and engraving off center

After trying to change the setting in console, it would allow me to change the settings, but they would not stay that way. I have read that xtool will not allow you to adjust console settings. Soooooo no change at all :frowning:

Don´t try that, my idea is if you reinstall the firmware with XCS, maybe it will “install” with X=430 Y=400.

let me try that

1 Like

I was able to get the firmware updated via developer mode, but the values in console did not change. Still $130=432 $131=406

You have to contact XTool, for a correct procedure to change those values.
Sorry.

No apologies! I greatly appreciate your help!

And if you try to adapt the Lightburn to X and Y, then check the center and make sure the laser doesn’t hit the rails.
In the device I sent you, try changing the height and width values.
image
And check if the center is dead center.

same result :frowning:

1 Like

i just ran same test in XCS and got the exact same result so it appears to be hardware related and not software like i thought.

But if you home the laser and jog the laser head to X=432 does it stop near the rail or does it hit the rail?

It stops near it, it does not hit the rail

With the device I sent you set width to 432 and height to 406 then Restart Lightburn and test the file below.
The file below is 2 crossed lines locked at 216x203 set to not frame, use it as a reference point for your workspace center.

Grid_center_432x406.lbrn2 (3.2 KB)

Sorry for the delayed response. Work has been kicking my butt lately.
I tried loading what you sent me, but it says your version is 1.7.00 mine is 1.603 and it says I have the most recent version. Also, I sent a ticket into xtool and they had me update my firmware and now, when I test, everything frames fine but it does the job right above the area I just framed. Like there’s an invisible piece above the job I just framed, and the software decides to do that instead of what I’m doing.

Ok, I got a warning about your file but loaded it anyway and it worked. I placed my “test” x directly over your crosshair and I got the same result again.


Type $$ and check if your laser $130 and $131 changed with the update.
Also try adjusting your pointer laser offset (both x and y).
Always click OK and then restart Lightburn after making changes to settings.

$130=432.000
$131=406

Laser Offset try X = -15 or -14 or -13 or change to other values and see if that works for you. To be safe click ok and restart Lightburn before testing.
I´m running out of ideas :sweat_smile:
image