Xtool D1 pro 20W running Lightburn has started scoring and engraving off center

Hi everyone and thanks for taking the time. Im a newer laser user, only been doing it for a few months now. As the title suggests, my laser is off center. Everything was fine until a couple of weeks ago. I had some templates set up and everything was engraving/scoring spot on, but now everything is 3-4mm to the right. This only happens when i have artwork on a specific space, coaster, cutting board, etc. This does not happen when I engrave/score and cut out the project, everything is fine when I do that. I have been reading some forums and saw about laser offset settings have been the culprit in others’ issues similar to mine. I use the offset because I use the crosshair to frame everything. I tried turning off the offset and it still did the same thing. I ran a test on a piece a cardboard checking center and saw the as the job started, the laser actually moved the 3-4mm distance before it started scoring instead of start location it should have. I have included a pic and some screenshots. Any push in the right direction is greatly appreciated. Thank you!

If you’re not intimately familiar with the behavior of the machine when set to “User Origin” as the Start From mode in Laser window, then I’d suggest switching to Absolute Coordinates and retesting.

Thanks or getting back with me. This happens weather I use absolute coordinates or user origin. I use absolute on my templates.

What is your workflow for aligning the design to the material?

I have a grid burned into a board that matches a tool layer in Lightburn. Before this started happening, I would just take a coaster, for instance, and lay it in the spot I burned for them on the board and then set my artwork in the tool layer and hit start. Always centered perfectly. Then all of a sudden, using the same method, everything constantly burns right of center. Even when i try to do a single using user origin, I will frame it perfectly with the crosshair and I get the same result. It seems like a setting I’ve messed up. I reset all the setting and I still get the same result. You can bank on it,.

You didn´t setup your laser importing the device settings file.
Create a new device by importing the .lbdev file and check again.

Thanks for the suggestion, I hadn’t don’t that. It, unfortunately, gave the exact same result, right of center. I have lightburn on 2 different machines, a macbook pro and a windows desktop. I get the exact same result with both computers.

Check if your settings are like the below ones.
Bed size 430x400 and not 432x406.

Yes its 430mm x 400mm

I still have not found a solution unfortunately.

If you type in Ligntburn console window:
$$ enter
$# enter
Also ? enter
and get some output, copy and paste the output here in a new post.











































Sorry, could you home your machine first and then type ? again and then post the output?

start_home x

left limit trigged

start_home y

up limit trigged






As a start you have to go to XCS and change $130=430 and $131=400
I believe you have to click a switch in XCS to be able to write to controller.

Thanks so much for all the time and help you’re giving me. I really appreciate it. I’ve been trying to google what you’ve asked and I can’t find anything. Would you know where I go in XCS to change those values?

I don´t have a XTool, maybe you could try typing in Lightburn console window
$130=430 enter
$131=400 enter
and then $$ to check if these have changed.
Maybe @LSS can share something more.


Unfortunately (well fortunately for me :wink: ) I haven’t encountered that issue…at least not yet.
And xTool doesn’t allow XCS to run without the laser connected, something I won’t be able to do just now so I won’t be able to check that for You either :frowning_face: .

IIRC such adjustments are “made” by clicking the tiny gear wheel symbol somewhere on the upper right hand side of the screen.
In quotes because sometimes the changes stick when XCS is closed, on most times, not.
Some changes do require the write enable to be on just as @parsec mentioned, some off in order 'em to stick.
Perhaps there’s some kind of a logic lurking behind all that, I for one sure haven’t found any.

Some changes IIRC can be made on the “device settings” or something like that in the pull down menus, but as I try to use XCS as little as possible, I can’t remember which changes.

If all else fails -and I unfortunately do think it will- back-up Your settings for reference, reflash the controller with the latest firmware, and make sure You’re using the latest lbdev. file.
While that does not guarantee smooth sailing, it does reset the system into most likely working state.



1 Like

I will look into that. I really appreciate all your guys’ help.

Iwas thinking in other possible solution…
If you reinstall the firmware wit XCS will it reset or keep the settings?