xTool D1 pro crashing into frame and grinding

Hi, I’ve been having some trouble with the xTool D1 pro that I work with.
I’ve never used a laser engraver before, so I don’t know much about them and I can’t seem to find a solution to my problem. When I’m using Lightburn and I turn on the laser, it wants to go to the back left corner but when it gets there it tries to keep going and makes a loud grinding noise. The laser works perfectly fine with XCS.
My immediate assumption was that maybe the grid/workspace thing on Lightburn was too big but when I tried to make it smaller it still wants to go too far. After reading some forms and trying their solutions, still nothing works. I’m stumped and not sure if it’s an issue with the homing or if the sensors aren’t working or if it’s something else.
Please help!

Sounds like it is going where the limit switches are not. Does your machine have limit switches, likely left end of X-axis carriage and left front of the frame?

A picture of the machine would help.

Yes, I just sent pictures of them and a full picture of the machine

I cannot tell where they are located. Calling the marked corner FRONT-LEFT, where are the switches located on the machine?

Enter these commands in the Console window;
Then pasts the result in a TXT file and upload here.
You may not think so, but we are making progress.

Picture of the side you pointed to.
I dont know how to turn it into a TXT file so I’ll just copy and paste it, sorry





left limit trigged

start_home y







































No worry, we can solve that another day.
I see a limit switch in the corner, so that should be your 0,0 Home position. $22=1 says homing is enabled. We now need to do a little research before changing any parameters.

I noticed the $# command reported nothing. It may be your controller will not, or it might be the Show all was not enabled in the Console window. Can you try turning that on and doing the $# command again?

Power off, move laser to the middle of the machine frame, power up. If it takes off, enter $22=0 in the Console. Also disable the Autohome on power up in the Device Settings window. This will keep it from trying to automatically home.

If it stays put, then use the MOVE window to move the laser. Up arrow, back, Down arrow towards the front. Left arrow left and Right arrow right.

Let us know the results. “It worked” means the motions were all as I stated.

By the way, I forgot to say “Welcome to the Lightburn community!”

I tried the $# again and nothing happened, it just said “ok”, I have “show all” enabled.
I disabled autohome on powerup and it worked as expected, but when I tired to use the move window to move it they would not work.
Thank you for the warm welcome!

Try entering $X in the Console window, and see if it will move…

I had continuous jog on and that was why it wasnt moving, I turned it off and it moves when I hit the arrows now.

It just says “ok”


That is correct. Can you move the laser with the Move window now?

So, I think the problem is that for whatever reason Lighburn isn’t processing the right limit switch or something. At least I assume its a problem with Lightburn because XCS works perfectly fine with the laser. When it tries to home, it says

start_home x

left limit trigged

start_home y



yes, I can

Lightburn knows nothing about the limit switches. It is simply reporting what the controller tells it.

You can’t jump to the end of a diagnostic. I do not know:

  1. Are the jog commands correct?
  2. When Homing, does the laser travel in the direction of the limit switches/
  3. Do you have a bad or maladjusted Y-axis limit switch?
  4. Was it working okay (Homing properly) up until you started this topic?
  5. Was this problem first noticed when you started using Lightburn?

You are my eyes and ears. I cannot know what is happening from here without your help.

Just so you know, never move the laser while it is powered up. The controller will not know where it is located if you do that.

The laptop I’m using died and I’m waiting for it to charge but I get off work in about 10 minutes so I might not be able to answer your questions for a few days until my next shift, I apologize.

Really? What for? You did nothing wrong! When you can get back to it is fine. You are not on a timeclock here. We won’t go away. :grin:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.