xTool D1 Pro Homing Issue

I installed the extensions today. I changed the XCS setting to Laser Super Long and changed the Length in LightBurn to 930mm. Here’s the weird part. If the gantry is in the upper half of the machine and I press HOME, it goes to HOME. If the gantry is in the lower half, it moves 550mm toward HOME. On and interesting note when I enlarged my other Ardunio based CNC I had to change the $130 and $131 measurements. When I look at them using console in LightBurn they are $130=432 and $131=406. I would have thought that $131 would have changed to 930. I tried to manually change it in LightBurn by entering $131=930 but it won’t write to the controller. On a positive note the machine appears to move throughout the extended area. It just won’t home from the lower half. Any ideas?

Windows 10 64 bit
XCS v1.0.0-beta 6.8
Firmware V40.31.002.01 B5
LightBurn 1.2.01

Controller Settings
$0=1
$1=0.03
$2=0
$3=0
$4=0
$5=0
$6=0
$10=255
$11=0.0
$12=0.0
$13=0
$20=0
$21=1
$22=1
$23=0
$24=25.0
$25=3000.0
$26=250
$27=1.0
$30=1000
$31=0.1
$32=1
$100=100
$101=100
$102=0
$110=18000
$111=6000
$112=6000
$120=2500.000000
$121=300.000000
$122=300
$130=432.000
$131=406
$132=0

You may find success writing new settings to the controller by applying the write enable switch on the xTool D1 before entering your new settings in the Console window. Some controllers just won’t allow it. Please test/verify this and report back. :slight_smile:

xTool D1 write protect switch

No luck. It worked just like last night. I started by restarting the computer and the D1 Pro with the switch in UPLOAD (Unlocked) position. I started LightBurn and entered $$ in the console. It showed $131=406. I attempted to change it by entering $131=930 and enter/return. If I enter $$ again it shows $131=406, not 930. This is the only Ardunio based controller I have with a lock/unlock switch and the only one I’ve had issues with. It’s weird that if I load XCS, connect the D1 Pro and set it to Laser Super Long then exit XCS. I can start LightBurn and homing works as it should from any position until I turn off the D1 Pro. Once I cycle the power on the D1 Pro it will not home from the lower position. I can get it to home but have to hit the home button a second time.

I’m assuming you’ve seen this: https://support.xtool.com/hc/en-us/articles/7881720780183-How-to-set-working-size-for-Extension-Kit-in-LightBurn-

Yes Sir. That was one of the first things I tried. Tonight I’m going to try re-installing the Firmware Update V40.31.002.01 B5. Maybe it didn’t load properly. I noticed last night that the D1 isn’t saving the settings after being turned off. In XCS I changed if from Laser Short to Laser Super Long and everything works as it should until I turn it off. When I power it back on it’s back to Laser Short.