Xtool D1 Pro with new extension kit won’t go to home


I installed the extension kit and it will not go to home position. I have changed the work space size and installed the firmware. The machine will not go to home when I press the home button but I can cut and frame.
Thank you

If you did this, in this order you may have reverted the firmware back to the original work area size.

With everything connected and running, in the Console window in LightBurn enter the following report requests and press Enter after each one:

Please copy those reports from the Console window into a reply here so we can take a look. Looking forward to seeing what’s happening.

Hey, had the same problem.

Make sure you loaded latest firmware on to Xtool D1 Pro as there were 2 versions:

  • B4 version (XCH can only update to this one)
  • B5 version (is the latest one which fixes communication and homing for Lightburn and adds extension support)

To update to B5 version follows Xtool support page:

Worked for me !!

Let me know.


Just tried this but still not going home :frowning:

[xTool D1Pro:ver B5]











































$22=1 tells the xTool D1 to go home - the other homing parameters seem reasonable.

The $130 is Maximum X travel in mm
The $131 is Maximum Y travel in mm

In the Console window type the Following:
then press enter.
If this setting takes, your device should home properly.

I have not yet confirmed that settings remain changed and do not revert back to what was set when built. You may need to keep an eye on this. Please repeat the $$ test if homing does not work as expected.

More about Settings here if you’re so inclined: Grbl v1.1 Configuration · gnea/grbl Wiki · GitHub

1 Like

It didn’t change the $131. It can cut and everything seems to be good except for the homing.

Ok, the next test for the xtool involves the write enable switch.

xTool D1 write protect switch

When you’re ready, Unplug the xTool from the computer and the power and check which way this switch is flipped. If it’s locked then you’ve confirmed something really helpful that I’ve needed to know for a while now.

If locked, Unlock it, and reconnect it.
When connected, re-enter the axis change request in the Console window:
then press enter. Please check to see if that setting stays.

Some users had new engrave and communication problems when leaving that switch enabled or unlocked. Test it for a while on some non-critical work.

When you’re done for the day and shut everything off, unhook everything from the xTool D1 and return the switch to the locked state before powering it back up - if that’s where it was originally.

If the setting reverts back to the factory number again, then you may need to reach out to xTool support for further instruction. If we can’t make that setting change as intended it could be the results of a choice made by their firmware designer or leadership. The open source firmware is readily adjustable and I haven’t even seen so much as a switch to disallow changes to settings.

It has been in the unlocked position when I did the other entries in the console. Just now I did turn it off and unplugged the laser and restarted the laser re-entered the code when the typed in the $$ again the $131 didn’t change.

The rehoming was working before the extension was added.

Ok, i’ve tried all this and nothing is working to reset $131=936 for the xtool d1 pro 20w, the firmware from XCS says its up to date and wont allow me to update it, have the latest version of LB as well. I change it by setting it, and it goes back to 406, i also have tried updating it with the GRBL switch in both positions.

1 Like

Hi all,

I’ve been having the same problems with my D1 Pro 20w since I added my extension and have done all the things suggested in this thread.
I’ve attached screen shots of the new “B5” firmware update installed as well as the pre and post edits of the code ($131=932) and the Device Setting window. Despite power down & disconnecting, the xTool will not take the code the regardless of the write protect switch setting. However, the xTool no longer stops halfway up the “Y” axis as it was doing previously.
So that problem seems to be corrected despite the code not displaying the correct settings.

Now onto the new homing problem…The cable and or air assist hose preventing the xTool from reaching the “Y” limit switch. I’ve removed the 6" cable protector (not the snake skin) and added a cable tie above the “X” motor and even added a cable tie to keep the air assist hose on top of the gantry. Still, more often than not, they interfere with the xTool reaching the “Y” limit switch and the drive will continue run without the gantry moving.
Any advise to rectify this new issue will be appreciated.

Continued to add the remaining screenshots…

This thread was helpful and I learned a lot about console commands.

I had the same problem (upgrading 20W D1 Pro with the extension kit, can’t home as it crashes at the rear/back.

The problem was the placement of the piece of plastic that trips the limit sensor. No amount of getting cables out of the way would allow it to trip the sensor on the gantry. I moved the piece to use only one screw hole so it would be shifted ~5-8mm closer to the middle of the workbed, and everything is fine.

Pretty sure my devices holes are in the wrong place. Will post pics soon.


I finally made it back. 3d printed an alternative trigger for the limit switch and we’re in business. Shouldn’t have had to do this but it works.

1 Like


I ended up using Notepad++ and editing their firmware to get mine to work with extension.

“EnableProcessOffset”: true,
“GUID”: “VjLWUwNzUt”,
“Height”: 932,
“HomeOnStartup”: false,
“Info”: “”,

hope this helps anyone having this issue.


Hi Adam, did you edit the firmware bin file and reflash, or directly via the program ‘printer’ port ?
I’m thinking that they really need to produce separate firmware for the extended version - and swap the X&Y axes. You can easily change the bin file grbl settings to swap the axes and other directions, but you’d need to swap the stepper and sensor plugs too - it would be much easier if all done from the original source code - that would eliiminate any finger trouble issues doing it DIY :slight_smile:

Yes I edited the bin file itself and did the firmware update with my edited version. The most recent firmware corrected the x,y issue but not the workspace.

1 Like

Adam, would you please be so kind and give a little more information ?

Tried it with firmware V40.31.006.01B2_20230206.bin but found none of your Parameters.
Maybe you can add some screenshots or something? Or at least the line number ?
Wich “language” are you using in np++ ?

Thank you

1 Like

Where can I download the B5 version? I clicked the link but it tells me I don’t have authorization. I did login and I do have an account I did buy my D1 Pro from Xool.

Hey John I think ive read everthing on the subject of xtool d1 Pro extension and it doesnt seem to have a good finish is there anothe string to read on the subject I have a D1 Pro 10/40w with and extension and mine will not home and is also ignoring the sensors
Thanks for any help! Oh! firmware V40.31.006.01B2

1 Like