Xtool RA2 Pro rotary chuck

I’m struggling with consistent use of the chuck rotary. I configured chuck in rotary setup and that’s OK, I use Current Position/Center Dot - place my laser on the spot on the tumbler that I want it to start from to engrave/etch my image [my rotary is placed so that it sits in the middle of the X and Y frame of my Ray5] - what is when I hit circular frame, I get this message pretty regularly “ALARM:2 G-code motion target exceeds machine travel. Machine position safely retained. Alarm may be unlocked. (Right-click the ‘Devices’ button to reset the connection) On or near line 4:”

I have to fiddle around with the rotary placement, to get it to work, this is pretty regular. I must not be using coordinates properly. Can’t figure out why I get this message because there is plenty of left and right X and Y movement available for the laser head to move. I have gone onto YouTube and researched other areas and I just can’t seem to figure this out. I have an order for several dozen tumblers and I’m having trouble here. Any thoughts would help or directing me in another direction to learn. Somewhat at a loss here.

Continued from

When you get it ready to run the job, read the current position, and give us the numbers…

How big is the artwork, is it an image and how fast are you attempting to run it?


Rotary is not mirrored - I have no issues with proper orientation. Y is into Y1 on controller. That’s OK. Xtool base/stepmotor is to the right. The issue appears to be when I have the laser off, and the Tumbler in the chuck, I move the laser directly over the area where I want the engraving to be - and I choose Current Position [center dot of the 9]. then I turn the laser on. I can easily move the laser head 125mm millimeters to the left and to the right [Y axis] and forward and back [X axis]. My average graphic that I’m trying to engrave is about 75mm H & W. When I hit the dotted circular Frame, it moves slightly in one direction and then the issue comes up with it stating out of range. When I am in the move mode, I’ll shut the machine off again, put the laser where I want it, turn it back on - then go into the Move mode and hit Set Origin to see if that works, still an issue. I have to fiddle around with rotating the tumbler within the chunk to finally get it to work. Sometimes it can take up to 15 minutes to a half an hour to get it right. Real pain in the butt, I just don’t know what I’m doing wrong.

If you move the head then power it up, that is the 0, 0 location… if your art in in the middle, it will go out of bounds in two of the four directions…

This is why I asked for these numbers in the previous post.

Make sense?


Yes. Makes sense. I’ll place the laser head in the front left-hand corner, which is the home position, and then turn it on. I’ll then try it. I put the rotary away for this evening, I’ll start a back up tomorrow. Thank you

This is probably bad advice but I hate ALARM:2! Seems to cause me much headache with the rotary since the limit switch can’t be used. Also autohoming then gives me a second error since it can’t find the home position.

So rather than deal with these two extranous errors and waste lots of time for nothing. I have turned both off… Just make sure not to crash the laser head, this is easy as the USB cable can only be so long and as your shackled to the dang machine just power off before it crashes. Make sure you know what your doing.

How, what do I enter in Console to turn them off? What $xx= entries do I enter? Thanks

Absolutely… It’s clear you don’t have your machine setup properly and/or you don’t understand the coordinate system and it’s associated controls…

Most people have a tough time with a machine that doesn’t home… it’s so much more work along with inconsistent results.

The reality is that it operates the same with and without… homing allows repeatable positioning. And allows start from options like absolute coordinates work properly.

These settings are to protect your machine and you have disabled them… The software knows something isn’t right…

Yes, it’s bad advice… you should take the issues one at a time and fix them so it’s working properly.

These things do work…

A rotary is just the table wrapped in a cylinder … no magic… it moves the rotary just like it would the table.


Well the ra2 doesn’t have switches so it can’t autohome when powering up the machine (it just spins for about one minute then gives error). And thus without it homing I need to disable the limits because then when I try and frame it throws an error, even though everything is fine.

What is the solution here other than turning autohome off and the hard limit?

Whats the proper thing to do?

You probably have to move the Y axes to the center of travel as indicated by the numeric position…

If it can’t home, then where ever it powers up is 0, 0… Meaning your rotary will out of the machine bounds… It’s the same as powering it up at one corner (being 0, 0), choosing job origin at the center, then trying to run a job … it will drive it out of the working area…

Make sense?


As you state - if I power it up in one corner it is 0, 0. Let’s say the laser module is in my front left at power on. You then say move the Y axis to the center of travel. Do I do that moving the laser module by hand - or do I use the Move function? After the move, do I don’t have to select “Set Origin” in the Move function? And…since I have a Ray5 with a Touch Display - I can set “Home Position” so, after the Move of the module to the center Y axis, do I set that has Home where it’s located? Plus, what type of coordinate do I need to use when powering it up - Absolute, User Defined, or Current Position? And if for the latter two choices, which of the nine circles should I click on - as you can’t click any the circle when Absolute Coordinates is selected. Once again, I appreciate all the feedback.

Once the machine has powered up, any manual movement by hand will cause the machine to be lost… it won’t know where it is… you do not want that. So use the move command to place any positions… including the rotary.

Home is defined on a coordinate system… this is 0, 0 . This determines which quadrant the machine will operate.

If the machine homes at the front/left, it’s operating in quadrant I. This defines the work area to the right of the Y axes and up from the X axes.


If back/left it’s operating in quadrant IV. The work area here is to the right of the Y axes and down from the X axes. Many of these machines operate on only positive integers, Lightburn uses only positive integers… Here the value of 10, 10 will go down and to the right…


When you use something other than absolute coordinates the allowed option is the job origin selection. This tells it where the artwork is related to the 0, 0 or user origin. You use the center dot, meaning three of the four areas will be out of the work area.

Does any of this make sense?


I somewhat understand what you’re saying - and finding out that I need to use the move command to move the laser head when the machine is on, other than moving it manually, is now understood. So before I turn the machine on, if I say placed the laser head at 200mm vertical 200mm horizontal - the exact center of my work area which is 400 mm x 400 mm, that means that the center is 0/0, correct? If my rotary chuck engraver is directly under the laser head at 200mm, 200mm, “0/0” when I turn it on, I should have plenty of movement in both directions - and should not get any kind of error from out of bounds or whatever. Correct? If my laser head is at 200 mm vertical and 200 mm horizontal, and turn the machine on, how should I set up the coordinates - choosing User Origin or Current Position - and which dot should be selected? Or do I select one of those options and which dot before I turn the machine on when at 200mm/200mm? I know I have a lot of questions and I appreciate your feedback, it’s been extremely, extremely helpful. I’ve learned quite a bit in the last four months using LightBurn and feel pretty proficient with it - and learning more every day and probably will be forever, but this issue has stumped me.

No, when you power it up, it will be at 0, 0 as far as the controller is concerned… even though the head is at the center… the head location will be 0, 0 from the controllers standpoint.

Power it up in it’s home corner, then move the head to the 200x200 location… this will give you room…


Usually it’s difficult to tell where the center of a mug or object is… that is why I use one of the corners generally speaking.

For mugs/cups on a rotary, I prefer the center left… most of my mugs have a manufacturers logo opposite the handle. I want the bottom of the image above the logo, but centered on the logo.

Using the center left, I set the X origin while the Y has been moved to center of work area numbers… similar to the though process you are using for 200x200 example… but as I suggested.

This is a one-off mug I did for a friend in the valley… the image is mostly around the mug with it’s center above the manufactures logo… you can see it on the left of the town logo. Done on the co2 using LBT100 coating.

Not the best example… next time I’ll try and get more photos that more clearly shows the process.

Good luck


Excellent info. Gonna give it a try again tomorrow. Thank you, thank you, thank you.


Well, I gave it a try starting my laser with the laser module in the front left, home, position before turning it on and then after turning it on - I realized that when I have my rotary set up and I hit move, the only thing that I can move is the laser module along the X axis - left to right. The up-and-down arrows on move rotate the rotary chuck. So there is actually no way to move the laser module directly over the item on the rotary chuck that I want to engrave…using the move commands when the rotary is installed and selected. So, I shut the laser off, moved the laser module up the Y axis to the point that would be directly in the middle of the item [tumbler] I want to engrave - all the way to the left against the rail. I then turn the laser on, move the laser head over the item I want using move, and when I try to frame, I get out of bounds in the Y axis. I can use move to position the laser module left and right [X axis], but when I try and use move to rotate the rotary, I get out of bounds. I used current position, dot center left, in the coordinates. Tried the center dot - same issue. I’m still trying to figure this whole thing out. Hmmmm

After you manually home it with the rotary connected, you can only move the rotary one direction… if you try the other direction it will rotate out of the work area…

The work area is the same no matter if there is a rotary or just the normal table… there is no continuous rotation available with a rotary… it is just the Y axes wrapped around a cylinder…

If the rotary is at 0, 0, you can’t move it in a negative direction… the move window will show you which way you are attempting to move it… if down didn’t work try the up direction on the rotary.

I’d also set it for user origin, not current position… don’t forget to use the set origin button in the move window… after all the other positioning is accomplished.


I have figured out a way to use the rotary chuck…and it has worked every time. I start the laser with the module in the 200mm Y axis area [all the way to the left frame/rail] - in line with the center of the rotary chuck placed in the middle of the work area. I then use the MOVE command [right arrow] to move the module directly over the area on the chuck & tumbler that I want to engrave. I use User Origin - center dot. Then, I use the MOVE command clicking on the up arrow and rotate the chuck until it rotates 180˚ - the opposite side of the tumbler area I want to engrave. I then click on Set Origin. Voila! I can then click on frame and it works perfectly. I know it’s related to the X axis not being able to go into a negative area. So by rotating it with the move arrow, up, I’m going to the positive area and then when I had set original, everything works. It may not be the most practical way of doing it, but I figure out how to work it. I’m good with that. I’ve engraved a half a dozen tumblers already and it works perfectly. Again, thank you for your continued input.

Great. just what I asked you to do… a little more complicated but the same thing.

Have fun…


Yes, that little bit more complicated, but I got it to work. Appreciate again, your input.

1 Like