XTool RA2 Rotary will not spin

I recently got the xtool ra2 rotary attachment to use for both the rollers and the chuck but after setting it up and getting it all connected only the x axis moves and rollers will not move.
I have an ortur laser master 2 pro so i know i have to connect it to the y axis. I set it up using the rotary menu and select y axis and then put in the values that xtool recommends when connecting to a 3rd party laser. But it will not spin.
I have tried changing the value and it still will not spin the rollers even though it acts like it is. I am not sure if i am missing something in the settings or something else.
Maybe someone has had a similar problem and figured it out or maybe knows more about the setting that I may be missing.
I am just beyond frustrated that I can not get the rotary to work. If someone knows something please help.

Hey Ryan, where you able to get the rotary work? I’m having the same issue. Xtool rotary is not spinning and it seems to be not connected at all for some reason. I tried literally everything.
thanks in advance!

I had the same/similar issue, I have a Comgro Z1 and when connected to the Y axis it would seem to stutter, but not move. I took a multimeter to the stepper motor/cable and found that the connector pairs the RA2 cable came with did not align with what my machine was sending. I had to swap two of the wires in the connector to match. In my case I needed the 1,3 and 2,4 wires as a pair, where the RA cable provided had 1,2 and 3,4 paired.

I found that i one of the two adapter cables that came with the machine had a lose wire that had to be pushed into place. For the Ortur you have to use the black cable adapter that has two wires crossing over that sends the signals to the rotary.
Both the white and black adapters look identical with that one change. I would try both cables that come with the machine and if they do not work make sure the wires are connected all the way.

1 Like

yea I checked again and again… I have all connector wires right. I even tried the other wire but still no spin or any sound or movement at all… I already contacted customer support for Xtool.
hope they will help.
Thank you for your time and help!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.