Xtool RA2 Rotary Y-AXIS Error

Hi, I’m new to the Lightburn community. I own two lasers now, and am having an issue with the Xtool RA2 Rotary accessory. It keeps telling me there is a Y-AXIS Error. I tried engraving a 1"x1" square to test the function, but it came out 1" wide x 1/4" tall. This has been the outcome with multiple files. The width being correct, but the rotary is rocking back and forth instead of travelling. I can’t seem to find anything on the web that shows this same problem
I’ve been picking at this problem for several weeks, with no results. Rebuilt the RA2, reinstalled the belt, changed the axis channel, adjusted the mm per revolution, etc. I purchased this back in December and am now out of the exchange window. I don’t know if I am doing something wrong, or if it’s defective. I haven’t gotten a response from Xtool either. Can anyone provide any information on this issue? Any help is appreciated.

Did this ever work?

Usually when you have an axes error, it’s because you are attempting to move it out of it’s work area…

I am not familiar with the machine, so you’ll have to explain how you set it up…

Where did you get the information for the rotary setup gui when you enable the rotary?

Can you post a screen shot… you can just drag and drop it on the reply editor or use the upload icon download-icon-backgroundon the window tool bar…

The basic idea is pretty simple, so it’s probably some kind of configuration…

What type of rotary is it? Wheel or chuck?


also make sure that you have these settings in the rotary setup window. are you using the D1 pro?

also confirm that you have uploaded the machine profile for your machine which xtool has for each laser.

128mm per rotation
mirror output.
z axis

(xtool only)

the RA2 pro is both.

Amazing… and I bought two :wink:


You are not going to believe this! I started to go down the list of possible fixes that everyone in multiple forums so graciously took the time to provide, and I found a winner! There are two short connector wires that come with the machine, for the purpose of compatibility across multiple machines. The one I installed, though to my eye looked identical to the second, turned out to be the wrong one all together. I switched to the other connector, and hit the ground running. Now I finally get to experience the creative side of the rotary. I appreciate everyone’s help, regardless of the fix that worked. I have felt very welcomed by your input, and am grateful to you.

1 Like

Great, I’m glad it’s working correctly…

Never would have though you had multiple cables… I’ll have to ask next time.

Thanks for reporting…


1 Like

could you post a screen shot of the connector switch maybe to clarify?