XY Axis Issue Ruida 644XG

When I installed Lightburn it suddenly shrank my work area on the bed size. Basically the laser cutter thinks it’s 500 x 300 mm, but it is only using about 10 percent of the total area. I am not sure if that makes sense. I am using a Chinese made 50w cutter. I am not sure if this is a problem on the laser’s side or on the software side. Any help would be greatly appreciated.


The working area of your machine is defined by the Max Travel specifications on X and Y and is configured in the Ruida Controller. The settings for X and Y can be configured directly on the controller HMI, or you can access these settings through LightBurn from Edit : Machine Settings.

If it’s only happening to the Y axis, you likely have Rotary Mode enabled.

Thanks so much! I got it second hand and realized the Step Length (um) was cranked up to 40 so once that was reset to 8-9 it works like a charm.


There’s a ‘Calibrate Axis’ button on the Machine Settings window where you can enter a ‘requested’ length and ‘measured’ and it will calculate the adjustment for the step size.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.