XY Axis Over Scale

Good afternoon,

Recently I purchased an OMtech 80W red 28x20 eBay machine from facebook market place to upgrade from my Xtool. Im running the latest lightburn on my MacBook Pro. The laser had less that 20 working hours on it, and the previous owner ran a test grid to show me that the machine worked. Once I got the machine home and set up I was able to do about 5 small test on a piece of scrap material before the machine started giving me the “XY Axis Over Scale” error code. The machine will not do a full frame either. It may do 50% of the square, or just 1 of the lines and stop.

Upon talking to tech support it was ruled to be my motherboard and Y axis motor had gone bad. After replacing both and powering the machine back on I was able to run 1 test before the error code started showing up again.

Upon researching the topic I have done the following to try to eleimnate the problem with no luck. The “test” I’m referring to is a 1”x1” square in the middle of the grid on lightburn.

  • I have placed the laser close to the center of the bed and the material the same. Put the origin to “current position” and still get the error code.

  • I’ve tried putting the “Absolute Coordinates” in and get the error code.

-I’ve tried running the test square as a out line, and in fill mode and still receive the error code.

-I’ve tired lowing the beds working size from 700x500 to make sure it wasn’t set incorrectly.

-I’ve changed the square to the word “Test” that was 1”x2” and get the error code.

I’ve spoken to tech support so much that they know my voice and name. Each time we get through most of their trials they leave me with “I’m not sure, I’ll need to speak with a senior tech” and I never hear back.

Please help me I’m tired of this machine collecting dust.

Thanks in advance

Hard to tell with these controllers… I’ve never seen that actual message before.

Might want to set your start from to user origin… move the head to the center and press origin on the console, this will set your user origin.

Then try the run… No need for the lpw or laser supply to be on, as you’re checking the controller.

Might also try ensure there are no un-needed files on the Ruida… they are kind of grumpy if they run low on memory… If possible, remove them all… :grimacing:

Go to Edit → Machine settings and save to file option… this will save the current machine configuration in case you goof somewhere… I make two copies… One local the other on my google drive in case I want the factory settings back and the local copy is corrupt… Cheap insurance.

At this point, let us know what’s happening…

Good luck :pray:


Before anything else, do as @jkwilborn suggests: delete all the files downloaded by the previous owner. You can do this from the machine’s console without involving LightBurn.

Some basic questions:

Does it home correctly when you turn it on? The laser head should move to the right rear corner, bump the home switches, back off, bump again, back off, and then sit quietly, without the least trace of drama. When it’s done, the machine display should show both X and Y at 0.0.

Can you jog the laser head to all four platform corners using the machine’s buttons? Set it for continuous motion at about 100 mm/s and use the arrow buttons to move the head. This does not involve LightBurn, which eliminates some points of confusion.

If all that works as it should, then it’s likely to be a configuration problem rather than a hardware fault.

Or usually one of the rear corners… My machine homes to left/rear…


Ideally, the corner with the home switches, but ya never can tell!


When I got the machine it would not home correctly. It would try to go to the upper right and would crash. After talking with tech support and adjusting some of the settings on my own I was able to get it to home correctly and the corners display the correct 700 and 500 measurements.

I will try to clear the previous files tomorrow and see what happens.

Thank you to all for the replies

That implies the controller now knows where the head is in relation to the platform. I assume you have reset the controller X and Y axis maximum travel limits to match the hardware.

After clearing all the cruft from the controller memory …

In Edit → Device Settings, verify:

  • Working Size = 700 × 500 (matches controller setting)
  • Origin dot is in upper right (matches home position)
  • Enable Pointer Offset is turned off (disabled)
  • Turn off all the Z / U axis switches for now

The LightBurn workspace should now match the controller’s limits.

Use the Click to Move tool to put the laser head in the middle of the LightBurn workspace. Does the laser head move to the middle of the platform?

Click near each corner of the workspace and verify that the laser head moves to the corresponding corner of the platform. Does that work as expected?

If so, then LightBurn agrees with the controller’s layout and the problem is most likely in the Job Origin you’re using for the layouts.

All is done and the when using the “Click to Move Tool” it goes to the coorisponging corners and all places it is told to go. The machine is framing better now, but will only complete about every 3rd try at framing. And when asked to run the project it’s still giving the Error code.

Well, we’ve verified that the basic functions work and the locations seem good, so we can proceed with other problems.

Try this test:

  • Start with a blank workspace (File → New)
  • Draw a single 1 inch square
  • Select it and click the Move Selection to Page Center tool or tap P
  • Set the Layer Mode to Line
  • Set the speed to 50 mm/s
  • Set the power to 1% (so the laser won’t fire)
  • In the Laser window, set Start From to Absolute Coordinates
  • Start the job

Tell us what happens!

If it does not trace the square in the center of the platform as it should, upload the *lbrn2 file so we can take a look at it.

Have you actually seen that specific error code? I have not and I’ve gotten my share of them.

Wondering if we’re chasing the wrong suspect…?

There are some kind of scaling settings within the Ruida… could never figure out what they did, exactly.


We’re certainly ruling out some of the more common failures …

It’s running like normal!

I tried this same thing in “Fill” mode and the controller would beep and just show this

Now I can’t get it to do the X and Y but this is what I have.

That’s the next test, because the laser head moves in an entirely different way.

Previously, you reported an error: “XY Axis Over Scale”. Does that error still occur?

Starting from the same 1 inch square in the middle of the workspace you made earlier:

  • Change the Layer Mode to Fill
  • Set the Line Interval to 0.1 mm
  • Keep the speed at 50 mm/s
  • Keep the power at 1%

Start the job and report what happens.

The laser head never moved from home and it displayed the finished message sent in the first picture.

I do not know what you changed or what you tried before the second picture with the error message, so fill me in.

When I ask you to upload the LightBurn files, it’s because they help me see what you are intending for the laser to do. What may seem obvious to you is not at all obvious to me (or us, the many folks reading along) based on your descriptions.

Some of the problem will depend on the X and Y axis settings in the controller. Upload screenshots of the X Axis and Y Axis sections in Edit → Machine Settings → Vendor Settings.

My apologies, I was just trying to show @jkwilborn a picture of that error message. The only thing that I changed was the speed, power, and put it to fill mode.

I’m out of town now and will upload the light burn file and screenshots of my machines vendor settings this afternoon.

Thank you all again for all of your help, I feel like I’m actually making progress!

Here are my X & Y settings.

After speaking with a senior tech at OMTech it was found to a problem with my computer! My MacBook Pro doesn’t communicate with the machine as it’s supposed to. After downloading lightburn to a Windows PC and changing nothing else the machine showed no error codes, and framed the job and ran it perfectly.

Thanks again to all for your help, I’m sure I’ll be back soon!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.