Y axis jumping during burn

Any help would be greatly appreciated. I have a modifies Amazon diode laser engraver with a Neje 7.5 optical laser and a MKS DLC32 controller. Trying to do a print and started getting a jump in the Y axis after printing for about 20min. On last print I included a frame around it and it really went south with the frame not matching the engraving. The belts are tight and y steppers are just warm though the stepper drivers are hot. Any ideas where to look? Thanks in advance…

My machine as the same controller.
In the the preview window, when you simulate the burning, do you see that “jump” as well?

Have you see if the timing pulleys are correctly tighten?

In the preview i don’t see any skips. I checked the pulleys not to long ago and they were good. I’ve tried this several times and it’s not till the last section that it does the skips on every try. Never in the middle or beginning which makes me not think it’s the pulleys or belt. Wondering if overheated drivers would cause this since if it was a stepper it wouldn’t be an even strip because I have 2 y steppers. I tried slowing down the speed and that made the jumps change position and size. See attached. Faster gave several thin skips vs slow with wider strips.

Ok, I don’t think it’s a defect in Gcode.
I’m convinced this is a mechanical problem.
Now try to rotate the image 180º, and try to see if the defect remains in the same area of the machine’s working area. If this happens, I would check that the belts are not missing teeth or that they are not showing significant wear (taking into account that you have already confirmed that they are stretched).

It could even be the settings of the steppers, but this only happens after it has been 100% confirmed that it is not a mechanical problem.

Did you figure out the problem? My laser started doing the same thing.

It looks like i have solved the problem. MKS suggested getting an externally mounted high temp driver setup. But my fix was to 3D print a 4010 fan mount and install a 12v fan over the drivers. It appears the stepper driver was getting to hot because just finished my test print and it’s a desired. Attached fan mount pic and before/after pic.

I don’t known what steppers you have installed but they look like mine and I never had that kind of problem.
Aren’t the belts under too much tension? :thinking:

What matters is having a solution to the problem, however there are a few possibilities for this to happen.

  • The steppers are different from the ones I have installed
  • The axle is “stuck” due to excess tension in both the casters or the belt, as well as worn or even dirty caster bearings.
    Another thing I noticed now, this machine, as it has a stepper on the Z axis, has more load to move, this could also be a reason… :thinking:

I’ve got the stock 4988 stepper drivers. I never had that problem in the past either, which is why this problem was/is causing me such head scratching. I’m not sure if the drivers are just getting old or what. The Y axis motors were not getting hot, though after doing some serious back n forth the X axis gets quite hot, I had to tighten the X axis to eliminate some of the wavey edges on the left and right of the early test prints. I’m not totally sure what steppers are on it at the moment, just some stock ones the Chinese seller had a good deal on. I’ve toyed with possibly upgrading to linear rails and threaded shafts instead of belts. and I don’t have a powered z axis but have thought about it though.

1 Like

The second picture you posted seems it has a powered Z axis, but it’s maybe a manual axis. If you decide to power it keep that in mind, more weight to be dragged, more inertia = more effort for the steppers.
I’ve been thinking the same for mine too. :wink:

After what you reported, I would still do the following.
I undocked and refitted the drives from board sokets, and the cable connectors on both the board and the motors in order to eliminate possible bad contacts. I also checked the contact between the heatsinks and drives

What did you use for undocking the drivers? Do you have a pic by chance?

After power off the machine I pull them gently by hand, only with tip of the fingers. always with careful to not damage them.

I got ya. I thought you remote mounted the drivers like MKS suggested. Something like this I think.

Mine is just like this:

Ok so same as me, thanks. I’ve adjusted the y axis belts and getting ready to do my big burn so time will tell.

I hope the fan has solved the problem!
Go for it!

Well it was a success…

1 Like

That’s what we want!!! :wink: :+1: