Y-Axis reversed for jogging and framing after opening project designed for different laser

I’ve been using Lightburn for a couple of weeks with no issues - still a newbie but things worked as expected. Yesterday I opened a lightburn test file that was created by someone with a different laser. Since then, it has really screwed up my functionality. I use lower left as origin and typically create a saved position to get the laser to that location. Now my Y axis jog buttons work in reverse. Up arrows moves toward the front and down arrow toward the back. Not ideal but I could make that work. In addition, my jobs are setup to start from lower left - that’s where the green dot shows. But when I frame the project, it doesn’t start from the green dot (lower left). It acts like the dot is upper left and frames from there. Y axis is again inverted when framing. Limit switches get involved and the laser screams at me. I’ve deleted my laser, imported the xTool laser lbdev file again and I still can’t seem to get back to square 1. Device settings show lower left origin. Job origin is lower left and using Current Position as the Start From. What settings did this other configuration save that I am unable to change now?

Thanks for any insight!

If the origin is different from when the art was created, it will be in a different ‘quadrant’ so the image will be flipped.

You can select that whole thing and use the mirroring tools flip-horizontal, flip-vertical to correct the image.

This should not have changed how your machine works via arrow keys.

What else did you change?


When I opened the test project, things were reversed. Even after I rotated so they showed up correctly on the screen, they printed mirrored. Fine, it was a test file and I don’t need to use it anymore. But now, I can’t get back to my normal - even after opening a file that was previously working correctly for me. To my knowledge, I’ve not changed anything I didn’t understand - basically just the laser origin and job origin are things I’ve changed, then changed back to where I want them. Trying to save so new settings will be written again. Nothing else.

The things that control these are in the Machine Settings. If you haven’t go there and save your current configuration so you have a backup.

There is nothing in a project file that changes the configuration to do what you are describing…

Are you sure of the Origin in the Device settings?

Unfortunately I do no have one of these machines… so I’m not as up on them as some…

Maybe @berainlb has something on these that can help you out…


Can you provide the following:

  1. screenshot of Edit->Device Settings?
  2. full screenshot of LightBurn with a design loaded

It does seem like something was changed on the machine settings because I can’t find anything in the user settings that would account for this behavior. I’m new to Lightburn but a software engineer by trade. I don’t typically screw around with things I don’t understand so did not willy-nilly start changing things. The project is one that worked as expected prior to Christmas but now frames incorrectly. Hopefully you can see something I am missing.

Did you change the Origin in Device Settings to front-left? xTool machines are configured with Origin at top-left. This is likely why your controls are reversed.

Change Origin in Device Settings to top-left and retest. I suggest homing after changing the Origin although I don’t think that’s technically required.

Yes, I changed it to front left. It was front-left all the time I had successfully used it for all my Christmas gifts I made. Using Current Position and a lower left job origin, the project always worked as expected. Since opening the other Lightburn project, the behavior of the Y-axis is totally reversed using the exact same settings I did prior to opening this project. If you change the laser origin to front-left and the project origin is also front left, you’d expect it to frame into the center of the board. It doesn’t. It frames below out of the laser grid. My process has always been “home” first, then move to saved coordinates or jog toward the front left of the laser. Project oriented as shown. Then frame. If I frame the project shown in the screenshot, it starts at the location of the green dot, heads right, then down, then left, then up back to the dot. Previously, it started at the green dot, went up, right, down, left, up then back down to the green dot. Regardless which version is right, the actions of the laser behave differently than they did prior to opening this other lightburn project that used a different laser.

I suspect this may not have been the exact setup. Job origin is completely independent of Machine Origin in Device Settings so that’s likely not a problem. And nothing is keeping you from referencing the front-left of the machine in Workspace.

The only time this would come into play is during burns and in jogging controls. It’s possible that Origin was top-left previously but you were referencing front-left for everything else.

I’m curious about this because with version 1.3 LightBurn will automatically reorient designs created in one origin with your native origin. It doesn’t actually change your origin though.

What do you mean by project origin in this case?

Try this. Set Origin in Device Settings to top-left. This will likely move and flip vertically your current design. Reorient and setup as you always did.

Test. Does it behave as it used to?

I changed the Device Settings Origin to top left. That immediately took my existing project and mirrored it so it is upside down. When I frame the upside down ornament, it frames as it did previously - as I wanted. I was fairly certain my previous setup had the origin front left but… getting older sucks! Things are working like I expect now. Thanks so much for your help! Time to export the settings and take screen prints for future sanity checks.