Y Axis Start Position Changes Between Cuts

Please see the two images here.

The one without my finger in it shows a crop in on a burn that contains 6 rows of 10 circles, burned with the default optimization settings. The circles are all perfectly round and perfectly spaced each time I burn the test pattern. But If I burn the same pattern twice without moving anything at all…I hit START, let it finish, then hit START again…and you can see that there is about 1mm of y axis position difference on every circle, while the X axis remains constant and the circles themselves remain perfectly round and perfectly spaces. Just for some reason the entire Y Axis start position has changed even though I have not made any changes to the laser or the settings in Lightburn.

In the second image with my finger present, I did the exact same thing…but this time I had HIDE BACKLASH enabled in the optimization settings just to see if it would help at all. But as you can see, once again the circles themselves are nice and round and the spacing between the circles is consistent and correct according to the array settings…but when I hit START the second time, everything was shifted on the Y Axis by about 1mm.

If I let it finish and hit START again a third time, it will be at a different Y Axis start position…close to the other two, but not quite accurate.

I’ve checked my belts and they definitely seem tight enough. No noticeable slop and good tension all the way across the length of the belt. I’ve had little ‘hobby’ diode lasers before and they were oddly more reliable than this very expensive CO2 100w with Ruida controller.

Anyone have any idea how to adjust this? Or am I just stuck with a laser that is not capable of tracing the same line twice without a Y Axis offset?

What microsteps are your stepper motor drives set to?
In high microsteps the motor torque decreases, I’m not sure if this is your problem but something may be missing here , adjust your drives to lower microsteps and try again.

Thank you. I will have to check that and consider an adjustment. Wouldn’t an issue of that type cause errors during cuts, too? At the moment, the only real error I have is that the start position is not consistent…but during cuts/burns, things seem to be accurate.

1 Like

I agree this is most likely being caused by a mechanical anomaly. Things to consider:

  • Belt Tension
  • Motor driver configuration (steps, holding torque, etc)
  • Rail / rail bearings
  • Laser head mount / play
  • Speed / acceleration setting (causing skipped steps)

Over the course of a larger job, drifts or changes in the above mentioned may not be evident on individual items. But if you run the same job over (traversing over the processed material of the last run), changes in the alignment can be seen (as you have illustrated).

You could test this by positioning your laser head in the normal start position and pulsing the laser on a scrap piece of material (to make an index mark).

Run this job (with either the laser PSU off or with all layers set to zero power).

When the head returns to the starting position, pulse the laser again and check the index. Most likely it will be off on your machine by that 1mm in Y as you have described.

Now run the job again with no power on the layers and after, pulse the laser when the head returns to the start. You will probably see another 1mm shift (now 2mm shift from the first pulse).

One other thing to consider is any possible shifting of the material on the bed caused by subtle movement of the machine chassis. If the machine is not secured well, isn’t dampened, or if your bed has a free floating honeycomb tray, it’s possibly the material shifting.

1 Like

Thank you. I will inspect/check each thing mentioned carefully. Will also run the test you have suggested. Once I’ve gone through the list, I’ll come back with results. Thank you again.

After carefully inspecting/checking each of the areas suggested, I can say that the laser equipment appears to be in perfect shape with no issues related to Belt Tension, Motor Driver Configuration, Rail/Rail Bearings, Laser Head Mount/Play or Speed/Acceleration settings (tried incrememntally slowing things down with zero change in results).

Additionally, I tried your suggested test running the job over and over with the laser off - then pulsing the laser at the start and end of each run. The position did not advance progressively with each run; instead it just came back to more or less the same spot, but never 100% accurate to the first run start position.

There are some new clues, though.

  1. If I hit the RESET button on the Ruida controller between runs, it will line up 100% accurately every time - even across very large complex jobs like the 60 circle test print. So I suppose this is not entirely unlivable. It adds a few seconds between jobs, but at least it gives me the guaranteed results I need to feel like I can produce professional quality work.

  2. When comparing position data in Lightburn against position data on the Ruida controller, there is .1mm difference for any manually set origins. For example, if I go to the movement tab in Lightburn and type in 400mm x 200mm as the origin and save that origin so that I can recall it at any time it will appear to work just right…except when you look at the Ruida controller panel, it will say 399.9mm x 199.9mm instead of 400mm x 200mm.

  3. Another ‘clue’ about the overall health and settings of the machine to take into consideration, especially in light of #2 above: I have printed several ‘rulers’ on both the Y Axis and X Axis to test/confirm that everything is accurate - and the rulers are dead on 100% accurate down to the MM across the full length of the cuttable area in both directions.

  4. One last ‘clue’ specifically relating to #3 above: When cutting a long ruler on the X Axis, a few of the hashlines are out of alignment on the Y Axis with all of the others. So, for example, with a 900mm (900 line) ruler, it will cut about 890 of the lines flawlessly, but two little chunks of 5 lines in a row will be out of whack on the Y Axis but still perfectly in line on the X Axis. This happens as the ruler jumps from section to section, basically during one of the jumps, it will end up in the wrong place, then it will go back to the correct place when it jumps again. So it is almost perfect, except for the rare and occasional misalignment. Interestingly - the misalignment is wrong in the exact same spot every time when I try to burn that ruler. By changing the settings in the optimization to burn from one direction without jumping back and forth it fixes the problem. But still makes me wonder why it has that problem at all - and why it happens in the same spot every time - especially when it is proven that the file is actually fine and not the cause of the problem by burning left to right without jumping around. If the file was bad, the ‘issue’ area would be bad regardless of the optimization settings.

So there ya’ go. A bit more history and maybe some useful clues?

Is it possible that these things are just part and parcel of owning/working with a large CO2 laser? And maybe I should just be happy that I’ve found ‘workarounds’ to fix every situation? I mean, sure, I’d love to have it work perfectly as expected every time without having to worry about optimization settings or resetting the controller each time…but those aren’t major difficulties.

Thoughts?

Just wanted to follow up and let you know that the microstep settings seems to be in line with the recommended numbers found elsewhere here on the forum. Thank you.

Anybody have any thoughts on the ‘clues’ listed above and how they might be impacting the performance of the laser? Specifically #2 really seems concerning unless I’m misunderstanding something about how Lightburn and Ruida communicate with each other.

The gantry will only be as accurate as the physical nature of it will allow. Unlike my CNC mill (where all axes are directly driven), my laser machine’s X and Y axes are driven with a belt (Belts and rollers and other points of potential slop).

Have you checked the controller settings to see if you have a .1mm offset configured? I think that is the Home Position option on X and Y:


Backlash settings on the controller can be set as well:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.