Z axis control tried to crash the bed into my laser nozzle

Boss Laser LS1420 with Ruida controller

Last night I was playing with a new lens and trying to find the best focal length. I was using the Z axis up/down control in LB with the increment set to .02 inch

I would click the Z up button and then pulse the laser to see the dot size, After doing this twice and not be 100% certain the Z axis was actually moving I clicked the Z up button a third time and the Z began moving up over an inch and was about to crash into the nozzle before I hit the eStop.

I thought I may have done something wrong, so I lowered the Z and tried again, this time I think it was the 4th or 5th button press of the Z up and the Z began moving upward toward a crash again.

Is this an issue with LB or with the Laser?

PS - can the Admins change the 15 character minimum for Topic Names? Sometimes I really do not need 15 characters.

The idea with the 15 character topic name is for people to provide more descriptive topic names :slight_smile:

In my case it made me add extra characters that were not descriptive. How about a min of 10 characters?

I noticed that. We’d like you to use more words to describe the question in the topic name.

You might not need the 15 characters, but we do.

OK, I will just pretend I am being paid by the word.

1 Like

We’re trying to avoid topics like “not working” which we see startlingly often over email.

Regarding the Z, that’s very strange and I’ve not seen that behavior before. If you have RD. Try it there to see if it exhibits the same behavior?

1 Like

I had a previous discussion about LB Z axis movement with respect to multiple passes. I was told that LB did not actually know where the Z axis was at and was just trying to do an absolute position command based on where it thought the Z was at and where you wanted it to be.

Could that have anything to do with LB moving the Z in an unexpected manner?

Ruida doesn’t support relative Z move commands in cut files, but they do have relative Z commands for “immediate mode”, which is what the arrows use, unless you have the “Move from origin” button checked in the Move window.

1 Like

I have never turned on the “Move from Absolute Machine Zero” because I was not 100% sure what it would do and the movements seemed to work fine with that control turned off.

Now might be a good time to learn what that control button actually does.

Funny, I had a similar problem on my Bodor with a Ruida controller, but all of my movements were either manual or using the auto-focus. I’ve had several minor head crashes because of that. No movement commands were being made from software, either LB or RD. This may be a controller issue.