Z Axis controls

I just added a proper z-axis to my machine and have also been playing with the settings in lightburn, i can say for sure that z-axis controls are pretty poor in LB certainly needs work but I guess most people using LB are just on 2 axis machines. There is a box in the settings window at the bottom that allows you to make the current settings default for all layers. As far as your z axis moving when offset is zero between files i cannot see how that could happen unless the offset is in your defaults for some layers, maybe noise on the control lines, or if you have 1 layer with an offset and move to the next and have optimize z moves on then its not going to put it back to zero when the offset file is burned. That’s how i keep crashing mine i can’t stand to see the z axis go from z to -35 on every line of the built in focus test but that also means when its done its sitting at -35 and any command after that will use that as zero point unless i tell it to go back to zero with a G0 Z0 command so if i want to do a quick second pass i crash the laser as it tries to move to -65. The z seems to not care what the max travel is set at,it won’t stop at it like x and y.

Along with continuous jog for Z I think the next best feature i would love to see is Home just the Z axis and if i set an origin with z=0 then when i say go to origin it should actually move z not just x and y.

Ok, I think you are saying you don’t like the way LightBurn provides control over Z Axis options. Maybe this will help you fully understand the options we provide and how they work together to provide the options supported. Let’s start there, then provide feedback as we are open to improving LightBurn when possible. Device Settings - LightBurn Software Documentation and for each cut setting, but this is for ‘Line’ mode (other modes are covered in the documentation as well). Line Settings - LightBurn Software Documentation

I do point out that you are using a different system than the OP, and should be considered.

Yes i get all those settings and have read the documentation where i can see improvement would be adding Z to the “move to position” in the “move” tab, continuous jog for Z, and if lets say i set an origin of 10,10 with z=5 I would like the “go to origin” to also move the Z. Having a separate “Home Z” beside the “Home” button would also be very useful.

In my setup when i home z it goes to the highest position and sets zero, i have 62 mm of travel down from that point, i have set the max z travel to 30mm, but if i jog z down it does not stop at 30mm, it actually wont stop at all and crash the bottom of Z if i keep jogging. When homing it seems to use max z travel since if I am at 45 down and home, it will time out since it didn’t reach the limit switch, I can fix that by putting the real max z travel in it for homing, I used 30 or half because i expected it to not move past the max just like x and y do and wanted to test it.

[quote=“renegade1966, post:1, topic:40647”]
Along with continuous jog for Z I think the next best feature i would love to see is Home just the Z axis[/quote]

I’m not aware of a command for GRBL that will do this. Are you?

That’s possible, but this would require the Z axis be properly homed, and many systems don’t have Z homing, or even Z controls at all. It would take some work to provide the UI for this, but it’s doable. You are correct that most LightBurn users have very limited Z control, if any.

I hope you didn’t read my post wrong LB rocks as far as software otherwise i would not have purchased it, my post is more about making it even better.

For jogging it works out of the box the commands are the same J$ as it is for x and y. I can confirm by manually entering a jogging command for z via the console so having that work in the move tab would be great along with adding an input box for z in the move to section.

As far as homing if #define HOMING_SINGLE_AXIS_COMMANDS is un-commented in grbl firmware before compiling you get $H, $HX, $HY, AND $HZ for supported homing commands at least in my 1.1h version of grbl.

I just flashed my mks dls 2.0 with that option and can confirm the commands work, as a fix at least I can setup some macro buttons for now to do that so its doable with firmware options turned on but it would be a nice option to see those in the UI if you enable the Z axis in the settings. I find it useful since as an example yesterday i was burning something where i needed z =30.2 so i needed to send a manual G0 Z30.2 command to focus my laser before doing a shift-frame command, but if you forget to put it to zero before starting it crashes now i can just hit the home z macro to get it back to zero without effecting any user origins i have set, i can even put it as the first line of my gcode so it always homes Z before burning.

On the last issue I think the option to move Z to zero when you go to origin would actually stop people from crashing the axis, right now if the z is other than zero and you say go to origin and forget its not at zero it will crash as soon as you burn a file. I know i can turn off optimize z moves and have it return to zero each time but it just seems like a lot of extra movement if you watch it burn a focus test in that mode.

The biggest thing is the z max travel issue, if i try and move any other axis past the max settings it stops moving, but the z does not do that most of my crashes yesterday would have been avoided if it stopped at 30mm which is what i have z max travel set at, seems like z max travel is being used to seek the home switch but not once its at zero.

A word of caution on enabling HOMING_SINGLE_AXIS_COMMANDS

Under Lightburn this works perfectly.

Under LaserGRBL there is an issue I am currently testing, when i tried to access my controller with LaserGRBL it locked up the serial port and turned the laser on full power requiring a power down cycle. I am going to flash without the option and see if that issues goes away if it does i will post it on their forum.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.