Z-axis issue on Ruida controller

I am having issues with the Z-axis function. The Auto-focus function works properly, and I can set the focus from lightburn, however the Z-axis up and down function does not seem to work on lightburn for my machine. The odd thing is that I see the Z-axis coordinates updating, but the honeycomb tray is not moving. (it moves during autofocus, but not during jog.)

If I go back to my panel on the laser, and press the Up and Down buttons it moves my Z-axis. (the weird thing is that is is listed as a U-axis for up and down buttons on the controller touch panel) Am I missing something? Z-axis moves the honeycomb, and U axis is for Rotary (as far as I understand).

I am trying to adjust my z-axis height for better cutting, and I am finding it impossible since I cannot adjust my Z-axis. Once autofocus is set, I cannot force the Z-axis position beyond the new “0” that gets calculated.

Please help as I have been spending 3 days trying to figure this out.

Ruida will initialize Z upon powering on / homing to 3000mm. Auto focus will set Z to 0mm. You cannot move Z up (inward) from 0 (not through LightBurn or from your Ruida HMI). You can move Z down (outward) from 0. None of this will affect LightBurn’s functionality for Z on your controller.

If you intend to raise Z after you have set the focus with auto focus, then you will need to reset the controller and allow X and Y to re-home and Z to be reset to Ruida’s arbitrary 3000mm (and your Z will be at your focused height).

Within LightBurn, can you verify that you have enabled Z Axis Control:

@LightBurn: I just observed that when Z is focused / set to 0, if a layer is set to offset Z inward then the layer will run (without moving Z) and lower Z when it is finished (as if it had been raised).

I have Enable Z axis turned on… my issue is that I cannot jog the Z axis up or down (but the auto focus function works). I am wondering if there is a controller configuration that may be missing.

I want to lower my focal length to cut 1/4" wood, and need to use the relative Z moves (or the material thickness setting.) However neither setting does anything on my Z-axis… (but the Z - Axis cordinates are moving on the lightburn).

Is there something I am missing?

I am really struggling here as I cannot cut through wood cleanly. (I am open to suggestions) I have run a ramp test and I can find my sweet spot… but can’t move my Z axis to it due to autofocus…

Red and Black, 60W autofocus with Ruida Controller (Firmware RX V23 01 06)

I don’t think you have a Ruida controller. Your firmware naming convention is indicative of a Ryxon KT332N controller. Ryxon is sort of a Ruida “clone”. If you do have this controller (the KT332N), it does not have Z axis control capability:


I suspect you do have this controller based on your description of the U buttons controlling your bed.

So I predict (and @LightBurn would need to chime in on this), your bed stepper drivers are signaled by the U axis of the controller / HMI. If this is the case, perhaps LightBurn does not (yet) support remapping Z to U.

I think you hit it spot on. I just bought this machine from eBay ( https://vi.raptor.ebaydesc.com/ws/eBayISAPI.dll?ViewItemDescV4&item=202961001499&category=46744&pm=1&ds=0&t=1606879875665&cspheader=1&versionid=2374582860010 )

and it stated a Ruida “control panel”.

I opened the hood and saw this inside:

did I just get scammed?


I think the controller is fine and should serve you well.

Let’s see what @LightBurn can advise regarding Z axis compatibility / remapping for this controller having no Z and U being used as a substitute.

I have the same controller. It does not have a Z-axis, but it does have a U-axis which controls the bed height. I confirmed I cannot raise or lower the bed using LightBurn either.

1 Like

James. My issue is that i need to force my focal length to cut better into 1/4 plywood. The autofocus does not let me go beyond the surface, and I since lightburn does not move the honeycomb up or down I cant make the proper adjustment… Do you have the similar issue?

Yes. Once you hit autofocus on the control panel, it resets the U-axis to zero. So you can go down, but not up. While I don’t have a Ruida 6442 to prove this out on, I do believe the behavior would be the same. The workaround is to either set the focus manually, or to hit the yellow Reset button on the control panel AFTER using the Autofocus, which will set the U-axis back to 1000. Both of these options will allow you to move the bed up or down using the up/down U arrows on the control panel (but not within LightBurn).

Notwithstanding the above, it would still be nice to be able to define what axis the bed is on so it can be controlled from within LightBurn, assuming this setting does not already exist.

I suggest you use a quality plano-convex 101mm focal length lens for ¼" material. II-VI (Two Six) ZnSE lenses are perhaps the best. You shouldn’t have any need to adjust the focus for only ¼".

I will add that you might want to identify the type of mirrors you have and consider replacing them with high quality Si mirrors. It is possible that the supplier of your machine didn’t use the highest quality of optics. Good mirrors and an II-VI lens will make a tremendous difference in the output performance “at the wheels” of your machine.

Laser Lenses, Optics, and Focus

What happens if you press one of these?

Oz is the man! Works like a charm.

That’s great! @LightBurn, would it be arduous to provide / write in future functionality that would remap the Z moves on a layer to A / U (maybe a configuration option in device settings)?

I’m not sure it’s possible, but I could check. The U/A axis is normally reserved for feeder use. I’m not sure if there are commands to move the U that will execute during a job.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.