Z axis Monport Board

I have a k40. Replaced the m2 board with a Monport… The blue one. I am trying to get the Z Axis to work. It will move with the move functions but will not home. I have tried Relative Z on and off… No help. I have a limit switch but if actuated it gives alarm 1. No matter what I do It will not home.

Any help would be welcome…


Jog the Z axis down until it is about half way between the limits. Then hit the HOME button. Which way does it go, up or down?

It does not move when homing.

Please explain what this means. G01 command or Jog buttons for just the Z axis? You do have a stepper motor on Z, right?

I see $22=1, so homing cycle is enabled. Also, $27=25.000 means your head will pull off the limit switches almost an inch, once you get homing to work. I think typical is more like 1.000 to 3.000 mm.

I have other questions about the parameters, but we will work on homing first. Awaiting your answers about Z.

Is XY homing working correctly? If so, it’s likely that Z-homing has been disabled in the firmware at compile time.

What version of GRBL is this running?

If this is a traditional version of GRBL then you’ll need to build your own firmware or possibly get one from the vendor if they have it available. If this is a more modern variant it may support runtime configuration for homing but based on the GRBL config shown that’s not likely.

UPDATE: I just viewed the S9 online and I see no z-axis drive. It is manually adjusted, so homing in Z is not possible.

If you purchased a 3-axis board, it will not work on a 2-axis machine. GRBL is compiled differently to accomodate the two designs.

But the thread starts with “I have a k40. Replaced the m2 board with a Monport”, so it’s not about the Sculpfun S9 in the profile.

So. Many. Lasers.

True, so I checked out the Monport K40 CO2 laser and it is the same. Everything I said still is relevant, right? Except the Monport replacement board, which I would expect to be a 2-axis board.

Even more fun when they play mix-n-match across brands with replacement components, no?

This all promotes the question: Why is the Z axis part of this thread? And what limit switch was tripped to generate the Alarm 1? Are we being tested? :nerd_face:

Yes there is a stepper on Z and a Limit switch

XY homing works as it should no issues at all. Adding Z axis to raise lower bed… Which actually works.
Z will just not home.
1.1F version

Z is part of the thread cuz I’m adding the bed raise and lower, which works with the on screen buttons and will raise as the cut/burn happens. but Z does not home. Thats all.
Monport board… grbl 1.1f

As indicated in my previous post then the firmware is simply not compiled with the ability to home Z-axis. You will need one that has Z-axis homing enabled for this to work.

You might be able to manually home Z by issuing G92 Z0 at your desired zero location but I haven’t tried this and not certain how that will work. This may also depend on $10 being set to 0. This is purely theoretical as I’m not sure what the behavior will be, however.

If you experiment with any GRBL changes, however, I’d suggest you document all your settings first. You can list them with:


This is a relevant piece of information and definately changes the dialog. When describing your problem, you have to be our eyes and ears. Guessing on our part is not a reliable means of troubleshooting.

Reversing what I said before, you likely purchased a 2-axis controller instead of a 3-axis one. Like @berainlb said, all is not lost, but you get to learn a new aspect of microcontrollers. Good luck!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.