Z axis not seeing limit

Have hit a bit of a wall and quite possibly not seeing what im either not enabling or disabling. Anyways bit of a story so apologies in advance.
Basically setting up a laser machine to do just rotary jobs. Have got a rotary ive made and still in the process of getting it to work but thats not the issue at the moment. So because i cant dedicate the U axis as i was hoping to control the rotary i have/making it to run on the Y axis. Since the stepper/s are disabled (that was the old Y axis) when you use the Y axis for the rotary, it doesnt lock in the position and could possibly move when engraving. So i swapped the leads on the old Y axis stepper across to the Z axis. Now i tried to enable the Z axis and tried a bunch of changes in the machine settings but the stepper wont take it back to 0 instead shows position 3000 as if the position sensor isnt working. however the senosr is working because when i jog it hard limits as well as when i auto focus it goes to position 0.

So to restate wanting the old Y axis to work on the Z axis just like the X or y axis does normally and later will set the z distance at say 100mm offset which lines up with the position of the rotary.

Oh also swapped the new z axis/old y axis across to X on the controller and it worked straight up.

Controller Ruida 6445G

You have done a good job confusing me…

I think a number of people use the U axes for a rotary with a 6445.

You have the configuration setup for limit switches on all three axes. That’s strange as there are no wires going to the controllers limit switch inputs… ?

There is no wiring to the Y axes home switch input either… ?

How does this actually home since some of the hardware is missing?

I see, you turned off the homing on the Y axes…

IMHO you are making a simple addition very complicated…

Good luck


Yeah I agree very complicated however I only went down this path because i could get the U axis to work for the rotary.

Anyways since your reply I have re wired and tried to get to work on the U axis.
So setup of the machine is as follows
Firmware flashed to the latest version i could find for the Ruida 6445G which is like .30
X and Y axis are both back to normal and operate as they should.
U Axis on the controller has the necessary driver inputs.
Driver is a TB6600 with 24v from the Power supply.
Driver set at 1A and 200 steps/rev
Stepper is 17HS08-1004S which says 1A rated current, 1.8 deg (200 steps/rev)

Enabled u axis in vendor settings via lightburns machine settings.
Start from set at ‘Current Position’

When turn on the machine and jog the U buttons, i get no response. I found that it would make a noise at me when I lowered the power to 0.7A and steps at 400 and it was wanting to try and move. But as soon as I upped the power to 1A it wouldnt respond.

I am open to suggestions on what to tackle next - have spent way to many saturdays trying to get it to work (part of the reason why I was trying the above by swapping it to the Y axis and then making the physical machines y axis the Zaxis)

let me know if there are photos that would help.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.