Z axis settings


I did modify my 7W laser engraver complete from the original Chinese laser engraver. U replaced the board for grbl 1.1 with control for 3 axis. Then I added the Z axis. I install limit switches for all X, Y and Z. So far so good everything works. When I home Z i do that in the upper part since I think is safer due I won’t damage my laser against the bed if something goes wrong.


My problem is:

When I home Z, the laser focal length, is too far from the surface of the material I want to cut/engrave. so I want to move Z down 40 mm (this will give me a focal length of 7.5 mm), to have it focus to the bed surface at that position, then I want to offset the material thickness so I can cut thicker materials. these are some of my setting in Light-burn. I have try pretty much all from the setting but not able to do so. Please any help will be much appreciated.


Is your Z limit switch at the bottom of travel, or the top?

I have both ends cover with limit switches the one on the top is covered due the install I did to hold the switch.

but home is in the upper position

you can see it in motion:

So now I have more control. In this example I am engraving a circle, moving my Z 40mm down as I want, then I set the material thickness 5mm then to do 2 pases. Settings in photo one

on the second layer I also move Z 40mm down, just one pass but every time X, Y travels goes back to Z home position then goes back to 40mm after traveling. How can I stop moving Z back and forth every time travels?

here are the settings for layer 2:

and finally the video showing how it works:

You can stop it from retracting constantly by enabling ‘Optimize Z moves’ in the device settings. It’s doing what it is to be safe.

Tears of Joy rolling down my face. is working like I wanted to work.

Texas Stile Thanks,

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.