Z moves are very slow

Need to edit this post.All I did was click on it and it posted it as mine. I did not originate this post.

The problem I have is the z axes moving very slow when using the move diolog. It seems to stutter while moving up or down and the only way I can stop the movement is to click on the stop button in the laser diolog. Thought the stepper motor was going out. Pluged the z into the y port and it moved as it should.
Went to easel and the xyz moved as they should. Also works ok using the off line controller. Do I have a command that got messed up lightburn? Thanks

Z moves have their own independent speed value for movement, because they often can’t match the speed of the X/Y table. Have you set the Z speed?


I have my Z speed set to 25. Where do I find the “focus Z” button? Don’t have one…that I can find.

The Focus Z button only appears for controllers that have a focus probe, and GRBL doesn’t.

Still have the same problem. Z moves with a stutter and very slow.

I reinstallled ver909 and still the same. Slow in all directions. Z still stutters

The laser moves like it should when burning. The original problem still exists.

Did you check the stepper drivers if they have the same configuration (dip switches)?

What is the firmware setting for maximum speed of the Z axis? ($112 in GRBL settings)

Do not have stepper dip switches

I will check the setting on $112 when I get back to the shop. Still don’t understand why things would change for Lightburn. All works well in other programs.

I have no idea - Z moves are just emitted like anything else, with G1 Z### F### (and the #'s are filled in with the appropriate values from the UI). You can just enter a G1 Z move into the console. If it works there, but not when clicking a move button, then something is up. If it moves the same in the console as with the move button, then you have a setting issue.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.