Z offset greyed out on LInux install but not Windows


I’m a fairly new user but I’ve been around CNC for most of my life. I built a large tabletop 100w CO2 laser and am running Lightburn 1.2.02 (supposed to be 1.2.03 but that’s another issue) on my Linux desktop PC for the laser control. The laser controller is a Arduino Mega/Ramps 1.4 running grbl-Mega-5X firmware.

The problem I’m having is I wanted to defocus my beam for some text on cardboard without cutting through. I though I would add a “Z-offset” but that option is greyed out in my Ubuntu version of Lightburn. I have Lightburn installed on my windows laptop with the identical settings and controller selected but the “Z-offset” is available. I have seen a few threads discussing this and each one did not have “Z enabled” in the device settings z control section. I do have this enabled and have tried every combination I can think of with the Z-enabled options. If I plug in my laptop to the controller the Z-offest does work fine. I also tried a couple flavors of GRBL (GRBL & GRBL-LPC) in the machine setup but have the same issue. I seem to have narrowed it down to a difference between OS versions. FYI I saved a project from my windows system with a Z-offset of 2mm and opened it in the linux version of lightburn then ran the file and it worked perfectly. My controller and machine are capable, why won’t Lightburn allow this Z-offset?

Devise settings on both systems

Ubuntu layer settings Z-offset greyed out

Windows layer settings Z-offset available

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.