4 days off , can monport work with this chinese power supply?

Hey all,

  • First off I’m completely new. never ran a single laser program on anything.
  • Secondly, I inherited an engraver that seems to have everything in chinese. There is no model, identification or anything useful printed on this machine.
    *It had the nano 2 control board. the machine is 600mm x 400mm
    *Its similar to the k40’s from what I can tell but not quite.

So Ive done enough research to know that I wanted to use lightburn and I bought a monport 40w board. I installed and it now connects to the laptop and the programs run. EXCEPT., The laser does not fire. (the test fire button on the PS does work)

I noticed the monport board then didn’t have the laser wire connected. It came with a wire that I connected to the control board but the other end didn’t have a place to plug in to.

My power supply , not sure of the wattage, but I took off the panel it says its a JG60-T V3.0 Sx150101150 . It list a website that is no longer in service.
It has 6 slots for the control board, |TH|TI|WP|G|IN|5V.

I’m looking for a wiring diagram of some sort to tell me how to configure this. I would and will just buy the compatible monport power supply , but I have 4 days off and I don’t want to wait the time it takes ship out anything else.

Can anyone help?

Aren’t we all…


Monport has changed the way these are connected so you might have to chase down some wires to figure out what is going on.

The lps is controlled via two wires. L (H inverted L) are laser enable. When this goes low, the laser will laser at a current set by the IN voltage or pwm.

Unless P is grounded to indicate the coolant is flowing, it will also prevent it from lasing.

Can you determine which is the PWM output?

:smile_cat:

Thanks you for your response.

I’m not sure which is the PWM output. I’m guessing this unit is the silver thing with the holes (heat shield looking thing)? The only wire going to this is a wire going from ground terminal to the ground terminal on the unit.

Most of the wires go to a digital readout on the top of the machine (from what I understand this becomes obsolete when using the monport board). when I try to remove these the laser no longer test fires(button on side of box)(wp is connected to ground).

I tried taking the laser wire from the control board, which is two wires and hooking the pos to the IN and black to ground but nothing, i tried hooking up one side to the TL and the IN but also nothing. Afraid I’m probably gonna screw something up but for lack of any diagrams, I’m clueless.

I did notice that the monport site has a very similar power supply with all the same terminals, yet documentation when it comes to connecting it all together is impossible to find. I know this can’t be too complicated.

If you can set the wiper of the pot to the IN terminal, one side to ground and the other to 5V you can control the maximum current… keep the knob in the center or less until you figure things out…

The PWM is wired to the H terminal…

I can’t tell anything about wiring from your description.

:smile_cat:

So I probably nearly blew this thing up. I had wired the laser control wire to the TL and maybe the ground, not sure. Then one of the capacitors on the power supply started smoking. So I shut it all down as fast as I could.

So I then removed all the wires to the basic config and fired it back up to see what damage I had done. It was running just like before, going through all the motions but with one difference. The laser was working.

It turns out that this thing doesn’t need the extra laser wire off the board. It’s the original wiring except I removed the 5v, the IN and left the grounds and the TL as they were. I did cut the extra wire on the Tl that went to the digital readout panel for + or - the power and test function.

Made some pretty cool photos so far, I’m not sure if the laser power setting is working as intended but that’s a problem for a different day.

I’m just going to update for anyone else running into this problem.

So this monport board replaces the nano2 version. Everything is plug n play except in my case the laser wire had no where to go. The laser wire is labeled CBI. The thing about this wire that I didn’t know was that it has a 3 terminal connector with only 2 wires. These wires are not hooked up to the same terminals on each end (Unfortunately Monport didn’t include this detail in the instructions). In essence, it matters which end you connect to the board. So it was plugging into the 24v and ground terminal instead of using the PWM. The other end, I had cut the connector off so I can manually add these to the power supply.

So to make the upgrade for the chinese laser, make sure the ground on the board goes to the ground on the PS, The PWM on the board goes to the IN slot on the PS. My laser was working without this, but I couldn’t control the power level.