4K Monitor Issues


I’ve owned Lightburn for a while but am FINALLY finding time to give it a shot I’m running Windows 10 on a laptop with a 4k screen and noticed the following:

  1. The detection wizard box when first starting up is messed up. I was able to get through it, but… it wasn’t easy.
  2. The icons and colors at the bottom are tiny. I found the slider, and made the icons larger. But the colors are still small (and the post I found mentioned that would be included in the scaling at some point, but that post is almost a year old now.

I’m wondering if there are any tips and tricks for 4k monitors. QT_SCALE_FACTOR doesn’t seem to make a difference (set as a system environment variable to a value of 1, per earlier post information)

I DID find QT_AUTO_SCREEN_SCALE_FACTOR works, setting it to 1 allows auto scaling and it DOES change the colors and icon scaling so it is much more usable, but text doesn’t seem to scale like it should (and not sure if that works with the wizard, I haven’t tried).

Are there any other tips/tricks that have worked for those of you with 4k?

QT_SCALE_FACTOR can be set higher than 1.0, but it scales everything as bitmaps and can look a bit pixelated. The palette at the bottom does scale with the icon slider for the next release. You’re the 2nd person today who’s brought up that font scaling on Windows isn’t working correctly. I’ll have to investigate why.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.