$58 laser looking good and cool

yes and no she said she wanted her money back, so I gave her my card.
And she took a mile and charged me interest. I asked her why such high interest
rate? She said, we are married, half of everything you own is mine, be glad I didn’t take it all !!!

1 Like

Well I hope you got a prenup, because if you ever split up then you will probably be homeless.
Was she ever in the money lending business and just wanted some vigoro.

Mr. W:
You got me rolling on the floor. 3 kids, 5 grand kids and one great rug rat. I don’t think we will every split up.
She told me once that, “we are married, everything is half and half. I have my half and you have your half
and half of your half is mine also, and you don’t forget that.” !!!
No money lending, but it took me 10 years teaching her how to save money. Today I bet she has 10x the savings I have. LOL.


I rest my case. :laughing:

I purchased an identical machine from Amazon for $80. It’s decent but the software sucks and I’ve not been able to get lightburn to work with it. Has anyone figured this out?

Check my post from higher up.

Also, this recent post:

Yes, Yes – I man on here gave me the program that makes it work with light burn. I have not been able to get it to work yet because I can’t read Chinese.

He includes an email address in this post if you want to reach out to him. That’s the only thing that will make this laser of any use with LightBurn.

WAINLUX jl3 compatibile with LIGHTBURN - LightBurn Hardware Compatibility [OFFICIAL] - LightBurn Software Forum

good luck with this thing. If you get working let me know.

If you already got files: here is the instructions:
Files have small executable and usually two BIN files. Bin files are the same, one named with version and another one just “rom.bin”. Uploader will take later file, long name file I guess in the case you have big collection of versions.

Assuming that driver for CH340 is installed and COM power appeared in Device Manager when JL1 is connected. If you are able to use original software then you are all set.

1- make sure uploader exe is not running, close if it is.
2- make sure board is OFF
3- hold button on the board, the one between power and USB connections and power ON the board
board now in upload mode
4- start the exe, follow prompts.

it is relatively fast process, bin is less than 40K.

5- reboot, start LarerGRBL and got to GRBL settings (that is for the board, not the app). At very least you have to disable hard and soft limits and set table size. If somebody cares - I can post my settings for that cheap Amazon Laser machine.

Just a reminder: there is no easy way back to stock firmware. I found apple app with very generic name “Laser engraving” by " [Dongguan Xinjia Laser Technology Co., Ltd" works pretty well with original firmware, but of course nobody want to do serious work from the phone and this is not a substitute to LightBurn.

USB chip is very generic CH340

USB/Serial is on UART0 and ESP12 is on UART1 of STM32.

Stepper drivers appeared pin identical to A4988.

Sal, you are a life saver. Now I can get mine going also. Thank you so very much.
Randy Cline ---- (the old fart) LOL

hey, I’ve done ST Link flashing and seeing V++ / clk / DIO / Gnd sure looks like the flash port.

I might have to get one just to bang on this and see if a bootloader can be loaded for easier flashing.

yes, please do if you would. I care!

One more question(maybe), do you believe it’s a stock DFU type of uploader( the Windows exe ) in which case any of the Python DFU uploaders would also work?

$0=6 (Step pulse time)
$1=255 (Step idle delay)
$2=0 (Step pulse invert)
$3=2 (Step direction invert)
$4=1 (Invert step enable pin)
$5=1 (Invert limit pins)
$6=0 (Invert probe pin)
$10=1 (Status report options)
$11=0.010 (Junction deviation)
$12=0.002 (Arc tolerance)
$13=0 (Report in inches)
$20=0 (Soft limits enable)
$21=0 (Hard limits enable)
$22=0 (Homing cycle enable)
$23=1 (Homing direction invert)
$24=600.000 (Homing locate feed rate)
$25=3000.000 (Homing search seek rate)
$26=20 (Homing switch debounce delay)
$27=10.000 (Homing switch pull-off distance)
$30=1000 (Maximum spindle speed)
$31=0 (Minimum spindle speed)
$32=1 (Laser-mode enable)
$100=80.000 (X-axis travel resolution)
$101=80.000 (Y-axis travel resolution)
$102=80.000 (Z-axis travel resolution)
$110=9000.000 (X-axis maximum rate)
$111=9000.000 (Y-axis maximum rate)
$112=9000.000 (Z-axis maximum rate)
$120=1000.000 (X-axis acceleration)
$121=1000.000 (Y-axis acceleration)
$122=1000.000 (Z-axis acceleration)
$130=220.000 (X-axis maximum travel)
$131=295.000 (Y-axis maximum travel)
$132=1.000 (Z-axis maximum travel)

Before flashing - read my other post about limitations with this (JL3) GRBL firmware.
Notably: No way to get hard limits/home to work properly, red cross pointer does not work (automatically), WiFi is no more, at least for me. And no easy way back to stock firmware, not like I will ever try.

Maybe some day we can recompile proper firmware for this board/hardware combo? I have started mapping signals to STM32. They do not match any GIT version, and there are a few. Should not be that difficult. Some day. For now this JL3 firmware will let us going.

1 Like

Wifi and red pointer don’t surprise me but surprised by the limits not working. That should be stock GRBL. What was the complication with homing?

May be good to press Wainlux on their obligations for GPL3 to release their changes. Ortur has recently indicated that they would comply so may be good timing to press other manufacturers.

Do you have any sense which GRBL variant is the base for the stock firmware? I’ve seen so many STM32 variants…

Flashing: my experience with this board/GRBL firmware, info to consider:

  • Flashing with JL3 firmware/utility is super easy.

  • Original firmware has some boot loader. I was not able to match it to any popular firmware loader, just does not talk. Maybe I just did not find the right one?

  • That original boot loader is gone after GRBL flashing.

  • I’ve tried to flash provided BIN with ST-LINK to Blue Pill - It loads but does not run. I’ve tried various offsets, including zero and the one that is standard with Arduino (something like 0h08000, do not remember exact) - does not run. Maybe something in configuration? Well, either way, none of my attempts to flash this bin to Blue Pill is talking over serial. I assume it just does not start. I would love to figure it out.

  • ST has utility for straight serial flashing, no need for other signals. Well, maybe need pulling high R19 and R20. But either way, once another firmware is available - should not be that hard to flash it again.

  • That ESP12 board there, after flashing, I was not familiar that GRBL by default has safety latch. This is my first experience with Laser and GRBL. It appeared to me that GRBL was latched/locked up randomly, preventing me from changing setting and any operation. I’ve speculated that GRBL cannot talk on two serial ports simultaneously, so I did pull that ESP12 off the JL1 board. Even without ESP board my apparent problem persisted. Then I’ve learned about soft safety latch and there are number of things that can trigger it - once behavior is understood - no problem. When messing with settings - once in a while I have to quit and reset the latch (command “$X”). Once all set - I have zero problems with this machine. It works pretty smooth and has surprisingly good results. But I have no WiFi and I cannot verify if that firmware can support serial and WiFi. But I do not care for WiFi anyway. I think it is better and safer without it.

  • There is alternative controller you can buy on Amazon: B07RQZGD35. It has no limit switches inputs, and you need to swap some connectors (no need to crimp, just pins swap, same type of connectors, but you need to buy JST-HX of proper size/pin count). That is hardware wise essentially identical to JL1, minus WiFi, minus pointer output, minus limit switches. And none of these peripherals working with discussed GRBL firmware anyway. Just a thought.


Limit switches are working but not matching smaller JL1 frame. The problem is that Lasers working in positive coordinate space. JL3 has Y home at far end and offset hard coded. No matter what settings are - after switch homing it goes Y negative like double the JL1 size. I’ve disabled all offsets and still, after homing with switches it tries to move negative. Check JL3 size. I guess it is possible to extend Y rails and move switch to far end, then it will work properly. As is, JL3 firmware homing with switches does not work properly on this JL1 frame.

In reality, I just home to bottom left by hand, before switching power on. To me - very minor inconvenience.

I suspect this could be overcome.

Were you able to get homing to complete with the switches? Where are the switch locations?

What is machine position post homing?

No idea. None on GIT that I’ve checked is matching default pinout, so cannot use any precompiled version. I also did not find any info if any on GIT support two serial ports simultaneously, but I guess this is not very difficult hack. It is also not a necessity, IMHO.

That JL3 firmware behaves like any other GRBL and report itself on boot as “1.1f” That is recent enough.

Cross pointer sits on dedicated IO. I was not able to toggle it with any g-code. It appeared to me that JL3 does not have pointer, this explains the lack of support. But no harm setting solder blob on board to permanently enable it.

I do not think it is very difficult to recompile from GIT, any of it. Just need some time. I got most of IOs mapped already, but more work is needed. Any volunteers?