8mp camera alignment issues

So I started with a cheap webcam I got everything to work just fine, only problem was the camera didnt cover the whole bed (900x600). I bought the 8mp camera and now when I try to align it (setting machine orgin to 0,0) when I hit the frame button it shows where it should cut but when I hit the cut button it says it is beyond my soft limits. Doesnt matter where I position it. I have a chinese laser running light object. Ay thoughts??

You need to run the laser in ‘Soft Origin’ mode (aka, absolute coordinates, where the position in the software dictates the location of the output). Trocen / LO-X7 doesn’t allow the software to change the working mode.

On the controller, press Menu, then choose Common Parameters Settings, then Work Mode, then choose Soft Origin. That should do what you need.

I get the same issues. I will try and get some pics uploaded. I have soft origin selected. Is there some other setting I am missing?

Here are some pics. one is camera view, other is overlay and than my soft settings

Do I select fisheye or normal cam? I got the 8mp 95 degree

When you did the camera alignment, were you running in Soft Origin mode? If not, that’s going to ruin it all. That job has to be run centered on the machine, and it looks like it wasn’t. For the 8MP you choose ‘normal’.

I was running soft origin yes, I have my machine 0 0 set to upper right, where it zeroes itself. Maybe I at wrong machine 0 0, when i change to lower left it reverses my screen like you showed on the video. Is there a way to find machine 0 0

Use this tool:

Click the corner of the workspace that has the red square (your origin) next to 0,0:

Wherever the laser goes, that’s the real origin.

Goes to upper right, laser seems to be responding to where i tell it to go, just cant get camera to overlay correctly

is it going to be camera lens or alignment? I get 0.1 or so on alignment and everything looks good until i hit finish. I have done both a half dozen times each with same results?

If you run the ‘Camera Alignment’ job, where does the output go?

You’re showing an image of about 30 different markers, which is making me think you might be clicking the wrong ones when tagging them.

Let’s start with this: Draw a 3mm circle in LightBurn, select it, press ‘P’ to center it in the page. Run that job. Then select the circle in LightBurn and choose this:


If the laser goes to the dead center of the circle, then you are in the correct mode to run the Camera Alignment wizard. If it doesn’t, your system is not using absolute coordinates for positioning, and nothing you do with the camera will work until it is.

If that part does work, use a fresh piece of material, focus the laser on it, run the Camera Alignment wizard with the largest scale you can fit in your machine. If you back out of the wizard, you may have to re-enter the scale again.

Did the 3mm test, hits dead center of the dot. Not sure what you mean by “If you run the ‘Camera Alignment’ job, where does the output go?” It outputs to the laser via ethernet.I will run the whole calibration later and see if it works. Like I said earlier, i was using a cheap webcam until I got your camera and everything worked fine, just didnt have the whole laser bed in the camera.

Reading more of the forum, My computer is 25 feet away from the laser, I am using a usb 2.0 “booster” cable. Is this my problem? The way my shop is set up, I run my laser and cnc plasma from the same computer. Would a powered usb cable help or fix? I am almost finished with my new shop where I could move the laser closer to the computer but as of now I am stuck where I am at. Maybe I am losing something over the length of the usb cable. Would a usb/ethernet work better?
Thanks for all the quick support by the way :slight_smile:

looking at setting my output was default to center, do i put in upper right?

What I mean with that is, there are 5 marks that it makes - the middle one should be exactly in the center of your laser, and the other four should make a perfect square around it.

The booster cable shouldn’t affect the alignment, but it could affect the image quality if the cable isn’t powered. USB over Ethernet cables usually don’t handle high speed connections very well.

It is all working now, just recalibrated and got all my setting correct. Thanks for all your help

Excellent - I realize that it’s a bit fussy, but it has to be to get the accuracy that it does. We’re looking into a couple different ways to try to make it easier.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.