A network error occurred: Error creating SSL context ()

I"ve just purchased a license. When I go to Help > Check for Updates, I get the error in the title.

Ubuntu 18.04.3 LTS
LightBurn 0.9.07, built Tue 2019-06-11 @ 14:34

Yeah, it’s been busted for a long time on Linux. Known problem.
I just watch the forum for new updates available…

This isn’t something I can easily fix - There are too many distro’s of linux, all with different versions of LibSSL in their kernels that aren’t compatible. I can’t recompile for half a dozen different versions of Linux.

We build on Ubuntu 16.04, and it’s tested on a few others. If I build against 18.04 I break everyone with older kernels, and vice versa, but it seems to be only the update check that fails, so it’s easily worked around.

Thanks for the reply. I understand the difficulties with different versions.

Why not run the latest? LightBurn 0.9.09, built Mon 2019-12-09 @ 18:00

IIRC I ran the beta of 9.09 on a Ubuntu 18.04.3 live iso and update worked.

Sorry, I tried to test this in 2 different bootable ISO environments(Ubuntu 18.04.3, Lubuntu 16.04) and for some reason I could not activate the trial periods on either system. If I get to the bottom of that, I will be able to recheck the ssl issue since I thought that was fixed in the 9.09 beta.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.