Able to cut and engrave on flat surface having problems with using rotary

I am new at this. I watched the Lightburn video " getting started with Lightburn : Setting Up and first project. I was able to do this but when I tried engraving on a wine glass with the rotary I started having issues. Got a lot of G codes, got those resolved but now the frame is not working correctly, the laser doesn’t move, stays in one spot, glass doesn’t rotate either. When I hit the laser button, the light comes on and laser works but also stays in one spot. I’m using the OrturM3 Laser and YRR rotary. Can you help?

Turn off ENABLE ROTARY switch and see if that helps.

I think you need the rotary enabled… if it works with the test button on the gui in Lightburn, then it’s probably some type of configuration issue…

Any other symptoms?


I just went through the 3 hour torture of trying to set up my own YRR. For once, I read and followed every direction to the “T” - three hours later, I put it back in the box without having made one successful burn. Next time I tried the YRR roller, I took it out of the box and hooked it up wihtout following instructions and made NO changes to software (i.e. did not ENABLE ROTARY) - and immediately had success.

My results may be atypical. But it worked for my setup. I don’t think it happened that way… I know it happened that way.

If this worked for you… I’d suggest he try it…

I’d also suggest you send a note to support, with version of Lightburn, computer/os and a link to this thread… this sounds more like some type of bug with that specific device…

I’m only saying it should work as designed… to turn something on, you shouldn’t have to disable it.

@JohnJohn can probably tell us more… :pray:


1 Like

Rotary is enabled

Ok, your switch is on.

Try turn it off and see if that makes a difference.

It worked for me, it may help you.

Here is another thread with the same issues:
Rotary only works when not enabled - LightBurn Software Questions - LightBurn Software Forum

I took your suggestion but now I’m getting a new message in console.
Starting stream

Stream completed in 0:00

[MSG:61:Error: Laser exposure timeout! Check TroubleShooting Section in User Manual.]

Ortur Laser Master 3 Ready!




GrblHAL 1.1f [‘$’ or ‘$HELP’ for help]

[MSG:’$H’|’$X’ to unlock]

[MSG:3:Warning: Caution: Unlocked]


When referring to the users manual about this it gives a solution to change power settings in Windows 10. The problem is I’m running Windows 11 which does not give me the same options in the control panel under the power settings. Does anyone know what I can do or how to change the settings in Windows 11 to fix this problem

Thanks marlene

I have no idea what the os would have to do with whatever they are asking you to change…

Like, what power settings?

Can you supply a link to the documentation you’re using?


I am presuming this is referring to the message in the console regarding my problem. Someone please correct me if I’m wrong.

Taken from Lightburn user manual troubleshooting:
USB port sleeping
If it thinks a connection is idle, Windows can put the port
into a power-save mode, which can make your device stop
talking to it. This is especially common with laptops.
If you are having issues where you often lose the USB
connection after a period of time, try the following:
Windows 7: Support Home Page
answers/detail/a_id/14917/~/disable-power-management-onwindows-7-machines 54
Windows 10: 202


I think this is what you want to do… stop it from timing out…

Let us know if it fixes the issue…


I have responded in your other thread: