Adding a diode to Ruida machine

I’m trying to add a diode laser to my Ruida CO2 machine for lower-power engraving. Specs:

Ruida 6445G(EC) controller
100-watt Reci tube
NUBM44 diode laser
J-Tech Photonics high-current laser driver

The driver has very simple connections: power in (from its own power supply), PWM in and power out to the laser.

I know these are connected properly as they’re clearly labeled on the PCB itself:

I have the PWM in connected to pins 1 and 3 (LPWM2 and GND) on the CN6 connector on the controller.

I’ve enabled tube 2 in the machine settings, and it shows up in Lightburn. I enabled it in the cut settings and disabled tube 1.

I set up a simple test file that consists of four lines 10mm long, each set to cut at 2mm/sec and each at a different power setting so I could watch the diode and see if it was changing power with each different line like it should.

I get zero response from the laser. The driver has a setting to switch from PWM to constant 100% power and the laser works then but I get no response on PWM.

Is there a connection or setting I’m missing on the machine or in Lightburn? I noticed some PWM frequency options when I was enabling Laser 2 but did not adjust them.

Thanks for any help!

1 Like

I’m curious if you got this working? Would love to add this to my own laser.

I did not. I tried every way of connecting it that I could think of and got zero response to the driver. I’m in the middle of making a separate 40x40 gantry for the diode laser now.

This thread might be of assistance. I had the same idea but never did attach the diode laser. I am also going to build a separate gantry.

I appreciate it, but I went over that and all the other threada I could find without success.

1 Like

I got it working with mine DSP controller…
I hooked up the TTL cables(+ -) to L-On and L-An accordling. Use the same pins your CO2 tube is using… I can see in the picture that it’s using L-On1 and L-An1, do the same, move the + from LWPM2 to L-On2 and from GROUND to L-An2.
Mine works fine even on pulse and the power changes accordingly to the settings. It works fine on RDWorks or Ligthburn.
I use the Laser2 offset in Lightburn and I can engrave with the diode and cut with the CO2(laser1).
You have to work out the speed as diode will be very slower. So, you will end up with speeds of max 30mm/s depending on your diode.

1 Like

Really appreciate the info, but I’m still not having any luck. I connected it as you advised:

And set up the machine settings in the controller through Lightburn:

And I THINK these settings are right on my test file:

For some reason though, when I set it as “Laser 2” in the window on Lightburn, and it shows “Laser 2” below it as enabled, when I go back in to the settings window (where you set speed, power, DPI etc) it’s defaulted back to Laser 1?

When I power on the laser driver with the Ruida controller turned off nothing happens but as soon as I turn it on the laser fires at 100%.

When I run the file the diode turns off and the machine runs it with the CO2 tube laser, despite me selecting Laser 2. As soon as the file ends the diode again fires at 100%.

Any suggestions on connections settings given these conditions would be GREATLY appreciated. If I can get this thing working in my big laser it will free up a whole motion gantry I have in another part of my shop and I can start building me CNC router there. :slight_smile:

Did you also disable laser 1?

Your wiring looks funny - Where do the red/black wires connect on the other end? (what are they labeled as?)

I have mine working but, when I use the diode I change the “tube” settings one of the none glas types.

1 Like

with pre-ignition you can have “low light” output to focus and see where it is going to cut.

Those go to the Control Signal Input ports on a J-Tech Photonics High Current Laser Driver.

Ahhhhh! So you have to change the laser type any time you switch from one to the other?

Ahhhh… no. I did not. I shall try that (and changing the laser type) later this evening when I get to test it again. Thank you!

Well all of that certainly moved in the right direction. :slight_smile:

Now when I run the test file it does NOT fire the CO2 laser and the diode DOES come on and shut off when it stops. Progress!

The only issue now is power. When it turns the diode laser on it fires at what appears to be full power regardless of the power settings in Lightburn. The Ruida controller also shows it at 2.5% but it’s just as bright as it is at 100%.

%$#&(#$&(!!!

You have L-ON2 and L-AN2 connected. Those are the on/off toggle and the analog output signal, respectively, but you’ve connected them to the same port as a signal and ground on the J-Tech controller side. I’m not sure what the difference between H4 and H2 is on the J-Tech controller, but I suspect you want L-AN2 connected to H2 (+) and the GND connection on the Ruida going to H2(-).

Ok, just tried wiring it that way and I get no fire from the diode at all, regardless of laser type settings. The CO2 tube fires as normal with Laser 1 Enabled and Glass Tube chosen in the controller but the diode is completely inactive.

:frowning:

I know this doesn’t help but.
This is diode and CO2 working together with the configuration as I explained above. CO2 didn’t cut through as I was testing and didn’t have right settings.

1 Like

@retrosmith, I just noticed something, my controller has on CN6 6 terminals and yours only 5.
Mine has ± for each terminal + ground and L-ANx – so, I’ve in order: LGND, L-OnX - , L-Onx+, LPWM2-, PLWM2+, L-ANx…
My cables are connected to L-OnX - and L-ANx… However, I’m not sure about your L-OnX if it’s positive or negative.
And my laser type is the same for both CO2 and diode - Tube glass.

I appreciate your help here, but I gave up.

I’ll just mount the thing on my CNC router and control it with UCCNC.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.