Adobe Illustrator looks filled, but doesn't translate filled to LightBurn

I traced and vectorized my logo in Illustrator. It’s filled in in Illustrator with the paths shown in blue around, but when I import into Lightburn only the paths (not the fill) remain.

Here’s what it looks like in Illustrator:

Here’s what it looks like in Lightburn:

Settings > Filled Rendering is definitely toggled ON

If I set “Fill and Line” it just turns completely filled in:

What am I missing?

see if all the paths are closed, they are probably not if it is a trace. I fear you have to inspect each path that needs to be filled and close or combine with the right other path to get the result desired, a lot of work. but you can start to set the outline of this big blue circle to another layer and see what comes up.

If you are willing, post the file so I can take a closer look. :slight_smile:

Thank you @Rick ! It won’t let me attach, but you can find the file here.

Amy

You had a lot of duplicate entities. When I put it into my CAD program, it showed 29,000 duplicates, and that was after I removed 1336 in Lightburn. It was going to take a lot of time to clean it up in CAD, so I placed the AI file in Photoshop, exported a hi res JPG, and imported it into Lightburn and traced it.
Here is a link to what I ended up with.

In Illustrator, if you set it to only fill with no outline stroke, when imported into LightBurn you shouldn’t get all the duplicates. Illustrator saves a copy of the path for the fill and another for the stroke, so just use one or the other and it should import cleaner.

There were no strokes in the original AI file. But, it had a lot of these.

Just starting my day, opened this file and started ungrouping. There are a ton of duplicate shapes and the original tracing done in AI created shapes that look like knotted string as shown. @RalphU did a great job unraveling. :slight_smile:

@Rick - I kind of cheated because I imported the AI file to Photoshop, exported to hi res JPG, then traced bitmap the JPG file in Lightburn :slight_smile:

Oh yay!!! Y’all are the best!! I’m guessing it’s something wonky about how I traced it. I’m not super Illustrator proficient and was mostly doing what The Google told me to do. Thank you!!!

1 Like

Noooo, not the Google! hahaha The trace image in AI can produce these odd ‘knotted’ shapes that cause issues. Adobe produced the trace feature to accommodate many uses, not specifically for path generation intended for laser production. We find the trace tool used in LightBurn to be a bit easier to get the results required for laser work.

Try using the built-in Image Trace with your next project and compare the results. It may be a simpler workflow for you.

Please mark this thread ‘Solved’ when you feel this has been resolved, so others can find when searching for similar issues. Thanks. :slight_smile: (click the 3-dots to expose)

image

Ohhh I didn’t know lightburn could trace! I’ll have to find where that is. Thanks!

This might help: :wink: Tracing Images - LightBurn Software Documentation