Air assist doesn't work, RDC6442S


This is Joost from from Holland.
I bought a Cloudray Ultieme Air Assist Set voor CO2-lasergravure en markering Machine on Amazon.
I have a laser machine with a RDC6442S-B (ES) and I installed the air assist set.
Unfortunaly it doesn’t work.
I installed the Pneumatic solenoid Valve with the + on the 24V and the - on de Wind (see attachment). But the light of the valve is very weak. When i put off the the wire side, the light getting stronger. I put also the Diode in it. With the wite line at the + side.

Also i read the machine and the air assist is enable. Also on the layer, but it won’t work.
I ussualy work with Lightburn, but i tested also with RDworks. But on both systems it won’t work.

Can anyone help me with this problem?


What is the second blue wire connected to? All the wire diagrams I’ve looked at only have 2 wires to solenoid. I have not set this up myself but have been researching this for about 2 weeks now.

The third wire is a ground when using the solenoid with some gasses.

FYI, Ruida switches the ground, not the positive, for the WIND and STATUS terminals.

Is the LED on during operation or just in testing? You have to turn in on in your cut layers.

Hi Dave thanks for your info.
I have wired the red one on the valve on the + site and on the mainboard on the 24V.
I have wired the blue one on the valve on the - site and on the mainboard on the Wind.
I don’t wire the ground one the motherboard with the valve. The blue one on the valve is not connected to anything.
The LED light is on when i wired the red and blue one.
I have put the air on on my layers and on the machine settings.
But you suggests to put the blue one on Ground in stead of the Wind?

No, positive goes to the + and negative goes to the WIND.

If you have the LED lit, but no air you either have a bad solenoid, or the wrong solenoid. It could simply be jammed from a bad bounce in shipping. Separate the solenoid block from the air block and make sure it’s not just jammed. Pop the top nut, and then a couple of little screws and it comes apart. Just a couple of small pieces internally, nothing to worry about losing or such.

Did you buy the actual air assist kit, or just pick up a 24V solenoid? Most solenoids need a minimum air pressure to function, and the little factory pump is well below that. The AirTac 3V208 is one of the few that will function with no input pressure. You can buy them direct on line, but be careful. The letters afterward designate the type of fittings it’s shipped with. I found out the hard way that NP and NPT are not the same. Make sure you get what works in your part of the world.

1 Like

Your wired up wrong if the LED varies in intensity. It should be on or off, it’s not analog. If the diode was in backwards it would just conduct and burn up. I don’t use diodes in mine and I can feel the solenoid ‘switch’ mechanically when it’s energized.

Dave is correct, the ‘wind’ is a ‘sink’ for the 24V. As he is about the operational limits of the pneumatic solenoid.

I know this is an issue with Cloudrays Ultimate Air Assist (UAA) kits, maybe it’s related? Some type of problem with the valves they supply.

Lightburn sends air assist “on” but does not send air assist “Off”

Part of the issue, is we can’t see what the wires on the solenoid are, where they go or anything that is of much help.

What wire is blue, what is red and what is black, what are their functions. Colors are meaningless without some kind of interpretation. Is the board on the solenoid marked with something useful to help identify what wire is used for what? Probably red is positive…

ASSUMING red is +, it’s a very simple wiring only requiring 2 connections, + goes to 24v and - goes to wind. Whether the blue or black is “-” is the question.

However you hook it up, The LED indicates it’s activated and the solenoid should be energized. It’s not a ‘power’ indicator as so many ‘hobby’ pcbs have. So it should be off if it’s not enabled by ‘air assist’ on that layer.

From what I know about the UAA that this relay appears to be the initial relay to allow air into the machine, which is usually connected to the “Status” (or ‘run’) sink.

This is the bypass solenoid on mine.


It kind of sounds like your controller doesn’t sink enough current to run your solenoid.
When you unpug the connector from the solenoid valve, the green LED is bright, and when you plug it back on the LED is dim. Is that correct?

Do you have a voltmeter you can check the voltage from +24 to WIND with the solenoid plugged in to the connector and again without it plugged in?

What does the solenoid do if you connect it to the 24V supple direct? Take the controller out of the equation completely.

If you connect it to 24 volts it should switch on. That’s all the Ruida does.

I had a problem with one, that I never solved. It works on 24volts from the bench power supply as far as actuating, but it doesn’t change the flow. It’s in my junk box, when I put my 30+ psi external air supply on the machine, I’ll break it out and try it at a higher pressure.

It sure looks wired right from his photos.
I think this is a problem with the wind pin not being able to sink as much current as the solenoid draws so the pin isn’t pulling hard to ground.
Would take about 20 seconds to check with a voltmeter…

I highly doubt he has a problem with the controller hardware.

It varies when he wiggles the wire. That does not indicate a controller problem to me.

There’s three wires there, how can you possibly tell? Especially with the blue and black…?

The wires should have some kind of nomenclature, symbol or something to tell us where they go.
Hopefully he can send us a photo of the board and wires that we can read. :slight_smile:
Maybe a link to the supplier?

He’s also Dutch, so there could be a language issue. :frowning:

You are limited to 500mA through the controller. Anything more than that and you need a relay in between to handle the current.

The low pressure causes problems for a LOT of solenoids. Most need a minimum pressure to activate. Don’t quite understand it, but that’s the way it is.

The AirTac 3V208’s are a 0 pressure solenoid, and the same one shipped with the kit from Cloudray. If you are using a compressor dedicated to the laser, the Cloudray kit is what you need. If you are pulling off a shared compressor as I am, then you need at least two solenoids and trash the rest of the kit.

You can take a look at my set up on my Google Mod Page. I have a minimum bypass for engraving, then a switch selectable hi / low for Premium MDF and Acrylic respectively. I use an ice maker shut off valve for my engraving bypass minimal air flow.

Look at the photos in the first post. It’s not “wiggling the wire”, he’s removing the connector from the solenoid. When the connector is plugged on to the solenoid, the green LED is dim. When he unplugs it, the green LED is bright.
That LED is wired across the solenoid coil terminals.
This tells me that plugging in the solenoid draws enough current to be causing a significant voltage drop somewhere.

Assuming he has the right wires… That’s the issue. Without knowing what’s what’s, we’re lost. I’m trying not to make this any more complicated than needed.

He can take the ‘wind’ connection wire from the solenoid off and just ground it, as that’s all the Ruida does. That would energize the solenoid. It should be that simple.

If that doesn’t work it’s broke or miswired. :frowning:

It also takes the controller out of the circuit.

Certainly connecting it directly to 24V would make sure the solenoid works. But it still doesn’t mean the controller can drive it. It wouldn’t surprise me a bit if it’s not the right solenoid coil and it draws too much current for the controller to drive.
I REALLY want to know the voltage between 24V and wind with the solenoid connected and not connected. That would tell much. Also would like to know the DC resistance of the solenoid coil. If the max output of the wind pin is 500mA then that coil better not be less than 50Ω, preferably quit a lot higher.

I won’t really know anything until I know what wire is what.

You and I both know it’s a simple connection. Powering it up will tell you if the solenoid is working, eliminating the controller. By working it manually, you can feel the mechanical mechanism switching. It tells you it’s switching, but not that it’s functional as a pneumatic valve. You need both the voltage and the pressure to ensure it’s operational. I try to blow through mine, but it could need over 2 bar (30 psi) as you pointed out. However the led fluctuating tells me it’s more likely there’s a wiring issue.

According to Ruida those controllers can sink from 300 to 500 ma depending on which document you wish to believe. Few of these size relays need more than 1/2 amp to pick them. Most of them seem to be around 150 ma.

Joost, you seem to indicate you enabled air assist. Did you enable it here?

Thanks for advise. I ordered a Voltmeter, so i can test it this week.
I will let you know.

Hi Jack, Tanks so much for all the info.
Yes i have enalble it there also.

I bought a voltmeter to check it out.
I will let you know what the result is.


This is very simple and you are making it very complicated. In this situation you can easily remove the controller from the loop. This will tell you if it’s working or not, as far as mechanically moving. If it’s doing that, that’s half the battle.

A voltmeter will probably confirm what the LED is telling you. There is a power loss somewhere. Then you’ll be back here wondering what’s causing it.

The problem is when you remove the ‘plug’ so you take the coil out of circuit and the LED changes intensity. That is some type of hardware issue. Try not to think, I need a new controller as in "I’ll flush $300 down the drain. :crying_cat_face: These things are pretty tough, look at the people who work on them :slight_smile:

The unanswered question is what is the function of each of the wires.

Two are needed, what color and what is the function of the third. If you ‘pick’ the wrong wires everything is a waste of time. The Chinese think right to left, does that give you a clue about trying to outguess them…?

Can we get a photo of the board and wires, hopefully with some kind of labeling, to get some clue as to why it has three wires and which is which. Then we can eliminate that part and move on.

Good luck :slight_smile:

The solenoid that came with my Cloudray air assist draws 303 mA. If the rated output on the Ruida is 300mA then that’s pushing it to the limit. If it’s 500mA, then not as bad.