Alarm 2 again (sorry!)

Please help me! I have an Alarm 2 error similar to those in other topics covered previously. I have read the other posts but can’t seem to find a solution.

ALARM:2
On or near line 2:
Stream completed in 0:00
[MSG:Reset to continue]

I am new to all this and am using a Ortur Laser master 2. This error just seems to have appeared randomly and I have no clue on how to rectify it. I am set to “absolute coords” and the GCode information is:
; LightBurn 0.9.14
; GRBL device profile, absolute coords
; Bounds: X6.78 Y188.98 to X273.66 Y381.31
G00 G17 G40 G21 G54
G90
M4
; Cut @ 10.1 mm/sec, 100% power
M8
G0X48.17Y247.07
G1X48.04Y247.11S1000F606
G1X47.69Y247.33
G1X47.35Y247.57
G1X47.03Y247.82
G1X46.72Y248.1
G1X46.36Y248.43
G1X46.03Y248.77
G1X45.7Y249.13
G1X45.4Y249.5
G1X45.19Y249.83
Thanks for any help or advice.

Alarm 2 is the machine telling the you it hit a hard limit or tried to go out of bounds. Where is the laser head when you hit the Start button, and how large is the working area of the laser?

It is at Home/Origin which is bottom left and the work area is 400 x 430

Is it possible that it’s in contact with the homing switches before you start? When it’s at the home / origin position, what does the ‘Get Position’ button on the Move window tell you?

The same error occurs when laser unit is placed randomly.

Playing around with the direction keys in the move window, I notice that the coordinates are totally off. By this I I mean, if I manually move the head maybe 20 mm on both axis, it appears to be moving from the maximum extension coordinates. So, from 400 and from 430 when it should be very close to 0 on both

At the home position, the get position reads x 400 and y 430

Type $# in the console and press enter, then copy the output here - there’s a strong chance you have an offset programmed for some reason. Did you tell LightBurn you had a Shapeoko or XCarve machine when setting it up?

Is this what you want?

$#
[G54:-400.000,-430.000,0.000]
[G55:0.000,0.000,0.000]
[G56:0.000,0.000,0.000]
[G57:0.000,0.000,0.000]
[G58:0.000,0.000,0.000]
[G59:0.000,0.000,0.000]
[G28:0.000,0.000,0.000]
[G30:0.000,0.000,0.000]
[G92:0.000,0.000,0.000]
[TLO:0.000]
[PRB:0.000,0.000,0.000:0]
ok

I think that I selected X-carve

In the console window, type:

G10 L2 P1 X0 Y0

That will clear the offset.

If you don’t have an X-Carve, you shouldn’t pick that. It will mess up your machine if that’s NOT what you have. You likely now have two macros for “Use Laser” and “Use CNC”. You can delete and ignore them, because you don’t have an X-Carve. :slight_smile:

Fantastic @LightBurn, all seems to be sorted.

MANY THANKS for your help with this.

Stay Safe!!!

hi! I am having the same problem and a few others, but these steps are not working for me. HELP PLEASE!

“The same problem” meaning that you also selected X-Carve as your machine type accidentally, or something else?

Well, Im gettin the Alarm 2 message, before that, the laser head started going past the bounds of the cut, even when I tried to (shift +frame) it. Now it goes busy when I try jogging it.

It’s most likely a ME problem, I am new to this as well, but I swear I had the settings right and made some really good cuts the first few times after that Initial Setup video.

Nearly every time we see this with an Ortur setup, it because the user is not in ‘Absolute Coords’ mode for the ‘Start From’ setting. Is that what’s happening here?

https://lightburnsoftware.github.io/NewDocs/CoordinatesOrigin.html

I have XCarve & JTech. I was using Current Position woth tue origin on the work piece bottom left.