ALARM:2 G-code motion target exceeds machine travel. Machine position safely retained. Alarm may be unlocked. (Right-click the 'Devices' button to reset the connection) On or near line 4:

It doesn’t matter what size file I use, I keep getting this Alarm.

Take a picture of Edit->Device Settings please.

It would appear your ‘working size’ is too large, I think the Olm2 pro has a working area of 380x320. You need to amend that in the device settings

I think @Mooseuk is likely correct about what’s causing this. However, the dimensions may not be correct for your actual laser. You list “Laser Master 2 20W”. Assuming this is correct your working area should be 400x430mm.


So I figured out what it is doing, but I don’t know how to fix it. All the size settings are correct in Lightburn, but when it burns, the Y axis is being stretched for some reason. The top is how it prints on paper, but the bottom is how it is burning.

Are you saying you’ve corrected your settings or are you saying that 900x900 mm is correct? If the latter, did you extend your laser frame?

The skewed burn doesn’t look like a mechanical issue so it’s likely a calibration issue on the X-axis. Check $100, $101, $102 - These should all be set to 80.

Also, is there a reason you have $261=0 in your g-code tab? You really shouldn’t have GRBL configuration settings in those fields.

The op’s console screen shot, showed an Olm2 pro, not what was listed, however that doesn’t seem to have solved the issue

What I meant, is the width and height show the correct measurements, but for the Y axis it burns wider then what it is set at.

100 and 101 was at 80, but 102 was over 2000, I changed it to where all three say 80 but it didn’t fix it.

The reason for the $261=0, when I first got my Pro the flame sensor kept going off, and that is what someone told me to do to disable it.

I have two lasers, an OLM2 that I increased the physical size to 900mm x 900mm, and a OLM2 Pro S2 that is at the factory size of 400mm x 430mm, but only one computer to run Lightburn on. When I do big jobs I use the 900x900, but when I do smaller stuff I use the Pro. I wish I could figure out how to make it to where I can select which laser I wanted to use, and it would change the settings automatically, instead of me manually changing the work are depending on which laser I’m using.

By the way, I wanted to thank you for your time and help with this.

Indeed you’re correct. Missed the boot info.

In that case dimensions should be 400x400.

That only need to have been done one time in Console, not in g-code tab. That runs every single time you run a job. Also, this is only relevant to your OLM2 Pro S2, not the OLM2.

You need to define a separate device for each laser. Click Device button in Laser window. Then do either “Find My Laser” or “Create manually” as you like.

Suggest you also update your profile to include bother lasers.

I now have both sizes listed in Devices, but how do I make sure both are in my profile, where can I add the second one?

Should I remove the $261=0, out of the G-code section?

So I figured out how add the other laser in Devices, and to make the work area change, but where do I add the second laser to my profile, or were you meaning by adding it in devices?

The only issue I having now with the image is, the Y axis is set to 180mm, but when I frame it the laser travels 360mm not 180mm.

Adding the device allows you to choose the relevant laser in the pulldown to the right of the port in the Laser Window.

Simply choose the laser you want to be working with. Device Settings and cut settings will be unique on a per device basis.

Yes. Remove this. It’s not doing any good and could potentially cause harm.

Make sure you’ve selected the Pro S2 and then check again. Review $100, $101, $102. Fro the S2 it should be:

$100=80.000
$101=80.000
$102=2124.000

I made sure all setting were at there default setting, per laser model, based on what it said on the firmware repository weblink.

What did you find and where does that leave you?


It will frame it like this, but the X axis only travels half the size, and the Y axis travels twice the size of what it is actually set for.

You have the rotary enabled. Disable that and try again.

1 Like