Alarm 2 G-code motion target exceeds machine travel

Good morning! I am a complete novice to laser cutting/engraving. I receive this error when I attempt to run a piece

[AUTHOR: RenShen]

[BUILD: Ortur Laser v1.2]

[DATE:22:23:00 - Feb 6 2020]

[VER:1.1f.20170801:]

[OPT:VZD,35,254]

Target buffer size found

ok

Homing

ok

Project loaded in 67 milliseconds

Starting stream

[MSG:Pgm End]

Stream completed in 0:00

ok

Starting stream

Layer C00

ALARM:2

G-code motion target exceeds machine travel. Machine position safely retained. Alarm may be unlocked. (Right-click the ‘Devices’ button to reset the connection)

On or near line 4:

Job halted

Stream completed in 0:00

[MSG:Reset to continue]

**I ran the # and this is what i received** #

[G54:0.000,0.000,0.000]

[G55:0.000,0.000,0.000]

[G56:0.000,0.000,0.000]

[G57:0.000,0.000,0.000]

[G58:0.000,0.000,0.000]

[G59:0.000,0.000,0.000]

[G28:0.000,0.000,0.000]

[G30:0.000,0.000,0.000]

[G92:0.000,0.000,0.000]

[TLO:0.000]

[PRB:0.000,0.000,0.000:0]

ok

Would anyone be willing to assist?

Seems to me you might
a) have something outside the machine frame (do a SElect all and see if you dont have a stray object outside the frame)
b) you using user defined dstarting point to your job instead of absolute coordenates or current position
c) You didnt home correctly

I would think b)

Did select all, only the imported object appears.

absolute coordinates or current position
image

Now I am getting the following:

ALARM:9

Homing fail. Could not find limit switch within search distance. Defined as 1.5 * max_travel on search and 5 * pulloff on locate phases.

ok

Homing

Ortur Laser Ready!

Grbl 1.1f [’$’ for help]

[MSG:Check Limits]

[MSG:’$H’|’$X’ to unlock]

ALARM:9

Homing fail. Could not find limit switch within search distance. Defined as 1.5 * max_travel on search and 5 * pulloff on locate phases.

ok

Ortur Laser Ready!

Grbl 1.1f [’$’ for help]

[MSG:Check Limits]

[MSG:’$H’|’$X’ to unlock]

[MSG:Caution: Unlocked]

ok

One and the other seem unrelated
With the alarm 9 i would - by experience ask yuou if you rpower supply is correctly attached
in fact, when you unplug USB -> just on power and power on machine does it do the homing cycle?

Alarm 2 is a origin issue

No. No movement.

This might sound silly but you sure your power supply is getting power?
Maybe the power strip is off?

I pulled a multimeter and checked the outlet. The machine is plugged directly in.

The machine is now homing on startup like it should, but using Lightburn it moved in the opposite direction of the switch.

If you send me an email address I can send a video

Sure you can support@ortur3dprinter.com

What home position you selected when configureing the machine in lightburn. LEFt/front?

Yes
Left Front

File is too large. Please try this link.
https://1drv.ms/v/s!AkErUClc4Kogh-sOTHND-Sx9TnDs1w?e=KD955F

you seem to ahve nstalled the wront firmware in your machine
Somehow you have OLM ( the little ortur) firmware in your OLM2
can you send me a email anyway so i can send instructions?

1 Like

On the way

Winner Winner ! Thanks so very much!

1 Like

Awesome!
Good one!

@OrturTech I’m having the same exact issue. I’m a brand new user. Is it possible I have the wrong firmware? I just received the machine today via amazon. Mind helping?

Starting stream

Layer C00

ALARM:2

G-code motion target exceeds machine travel. Machine position safely retained. Alarm may be unlocked. (Right-click the ‘Devices’ button to reset the connection)

On or near line 4:

Job halted

Stream completed in 0:00

[MSG:Reset to continue]

ok

Ortur Laser Master 2 Ready!

OLF 137.

Grbl 1.1f [’$’ for help]

[MSG:’$H’|’$X’ to unlock]

[MSG:Caution: Unlocked]

ok

#$

error:1

G-code words consist of a letter and a value. Letter was not found.

$#

[G54:0.000,0.000,0.000]

[G55:0.000,0.000,0.000]

[G56:0.000,0.000,0.000]

[G57:0.000,0.000,0.000]

[G58:0.000,0.000,0.000]

[G59:0.000,0.000,0.000]

[G28:0.000,0.000,0.000]

[G30:0.000,0.000,0.000]

[G92:0.000,0.000,0.000]

[TLO:0.000]

[PRB:0.000,0.000,0.000:0]

ok

You’ve probably changed the ‘Start From’ setting from the default ‘Absolute Coords’ to one of the other modes without understanding how they work. Read here: https://lightburnsoftware.github.io/NewDocs/CoordinatesOrigin.html

Hi, I’ve tried all start options (coordinates, user, and current) and they all throw an alarm 2. Any idea? I’m on hour 5 of troubleshooting

If using Absolute Coords, the machine has been homed, and the design actually fits within the usable area of the machine you shouldn’t get that.

Show a screen shot of your LightBurn window with the file you’re trying to burn, and then type $$ in the console window and press enter, then copy the output from the controller here so I can see (those are the firmware settings)

Same issue here. If I may:

error:15

Jog target exceeds machine travel. Command ignored.

$0=20 $1=50 $2=0 $3=0 $4=0 $5=0 $6=0 $10=0 $11=0.050 $12=0.002 $13=0 $20=1 $21=1 $22=1 $23=7 $24=600.000 $25=3000.000 $26=100 $27=4.000 $30=1000 $31=0 $32=1 $33=250.000 $100=80.000 $101=80.000 $102=80.000 $110=9000.000 $111=9000.000 $112=9000.000 $120=2200.000 $121=1800.000 $122=2500.000 $130=400.000 $131=430.000 $132=1.000 ok And: $# [G54:0.000,0.000,0.000] [G55:0.000,0.000,0.000] [G56:0.000,0.000,0.000] [G57:0.000,0.000,0.000] [G58:0.000,0.000,0.000] [G59:0.000,0.000,0.000] [G28:0.000,0.000,0.000] [G30:0.000,0.000,0.000] [G92:0.000,0.000,0.000] [TLO:0.000] [PRB:0.000,0.000,0.000:0] ok I homed my URTUR to front left and it homes correctly when I power it on. Set Absolute Coordinate. I'm using the trial version. Just got the URTUR LM2 yesterday. Also, the arrows in the Move Menu won't let me move my laser, I get the same error:15.

The problem seems to be in the description
You probably sent a Jog (move command) that is too big, in move panel how much mm are you trying to move? if its bigger than say 400mm in 1 jog, it will throw an error