Another newbie question

So I have my power scale ready to go. But I think I am doing something wrong. I have a 5500mw laser. When placing the material on the laser bed, i put it in the center of the bed and then place my laser on the bottom left corner of the piece of wood. Am I doing that correct? Because when I go to hit play i get a message that cut might be outside the bounds, continue anyway?

Where am I supposed to place the material and am i telling the laser correctly how to start my cuts? Sorry if this does not make sense

This is worth review to help in understanding ‘Job Origin’ and how to set up your job for the desired outcome. https://github.com/LightBurnSoftware/Documentation/blob/master/CoordinatesOrigin.md#coordinates-and-job-origin

1 Like

Thank you! I will review now

I am not sure what I did wrong. But while it was layering it started going uneven so I stopped it! Please help

@lovesnapped
Actually I have the same question but haven’t gotten around to address it yet.
I just hit the the start button (with my hand poised over the E-Stop) to continue and the machine does the job.
I have no idea as to why it says it is out of bounds when clearly it is not.
Wait for OZ to address it. he does a very good job at explaining to us newbies.

@Rick
A little more of an explanation would be very helpful to us newbies instead of just pasting the same statement every time.
I have read those instructions numerous times and there is nothing in there addressing the out of bounds warning window that pops up.
If I’m missing something please point it out and I (and all the newbies) will be appreciative.

@JVL oh yes. Your statement is VERY true
In fact it took me a couple tries to figure it out. I’m a complete newbie as well so it’s hard but I’m determined to get it.

Don’t get me wrong, I still have issues with my machine also.
Being a complete newbie, I’m very sure that its my lack of experience.
In fact OZ pointed out yesterday that I need to change one of my settings. (I didn’t know)
I’m on my way out to the shop now to make the change and try it out.
However, my statement stays the same. It is not clearly explained in the directions.
I’m glad it worked out for you, and hoping that I will have a productive day today also.

The thing Rick posted explains how the different origin settings work, but if you have a machine that hasn’t been properly zero’d there are more things at work.

LightBurn was written for dedicated laser systems, with homing and limits set properly. It will work without those things, but that’s what it assumes you have unless you tell it differently.

If your machine isn’t zero’d, then the system has no idea where you “are” when running a job - the zero point of the machine will just be wherever it was when you powered up. If that happened to be in the middle of the work area, you could have a situation like this:

The black grid is the actual work area of the laser, and the green square in the bottom corner is the origin of the machine. If the laser was sitting at the red circle when you powered it up, the machine thinks that is zero, and thinks the red square is your usable work area, which is obviously wrong.

Next, you draw this purple circle:

You jog the laser over to that corner and hit start, where you want it, and hit Start, using "current position’ as the origin mode. LightBurn asks your laser, “hey, where are you?” and the laser says, “I’m at -80, -80”. That’s out of bounds, and you get the warning.

To fix it, move the laser head to the front-left corner (or wherever you have your origin set), before you power it up, so that’s where zero goes, OR, jog the laser to that corner, and issue this command:

G92 X0 Y0

To use that, you’ll also need to have your machine sending its position in work-space coordinates. If you have an old version of GRBL (0.9 or earlier), it’s $10=2. For newer ones (1.1e or later), it’s $10=0. That means when LightBurn asks, “where are you?” it gets the answer relative to the new zero you set, not relative to where it was when you powered up. (zeroing before power up doesn’t need the above command)

OZ,
First, thank you for your concise explanations.
I don’t want to step on lovesnapped thread, so if you guys want me to take it to a new thread please let me know and I will.
However, it appears that we may have some of the same issues.
In an effort to start from square one lets start with this question.

You speak of a positive or negative coordinate system.
My X carve CNC has a 19" X 19" bed.
My X0 Y0 zero is in the lower left hand corner of the bed.
If I enter any dimension in either X or Y they are positive numbers and the machine moves in X from left to right and in Y from front to rear of the machine. (in a positive manner)
I can do this from virtually anywhere in the envelope.
(I never use homing as I always home from my work piece)
I can also set my start position anywhere I want (which is always my work piece) and the machine will always come back to that position.
Is this not a positive coordinate machine?

I will try to be as helpful as I can. This is your controller and hardware setup. I did not build it, I don’t know what is there nor how successful the build went. This is not my DIY laser system. I have been trying to provide you with resources that are produced by the supplier and have proven to work for many others that have the same setup. I will continue to offer as much help as I can, and when you have your gear set correctly, I can even help with LightBurn.

I am going to need a bit more of an explanation here. Looking at the picture are you saying that the laser was moving to different locations then firing the laser?

Post as detailed account as you can. More is better in the case.

Correct, it is not a positive workspace machine. If you run a homing cycle, and the machine homes to the rear-right corner, and sets that corner as zero, you will need negative coordinates to jog into the work area. This is common for CNC machines, and uncommon for lasers. Read here for a bit more info:
https://github.com/LightBurnSoftware/Documentation/blob/master/CommonGrblSetups.md#common-grbl-setups

This is easily most of your trouble in LightBurn. You are using it like CNC software, and it isn’t written to work that way. By zeroing to your workpiece you are eliminating the ability for the software to jog within the machine envelope safely, because you moved it. LightBurn enforces its own soft limits. By changing your zero point, the software can no longer know where the actual bounds of the machine are.

The ‘Click to position’ feature, for example, uses absolute coordinates, relative to the machine zero. If you move the zero, that feature won’t work, and neither will anything else that uses the location of the machine to figure out if you’re going to go out of bounds.
image

Zero the machine to the front-left corner (the origin) and leave it there. Then use the ‘Set Origin’ feature in the software to set the job location, and ‘User Origin’ mode when running a job. It behaves the same as what you’re used to, but doesn’t require changing the coordinate system.

@Rick I think I figured it out because now the bed does not move correctly. Looks like I have to take a part because a spring looks to have popped which probably cause the bed to not move correctly while the laser was firing.

Please let us know if you find you are having issue after doing this repair. We can pickup from there.

OZ,
I feel like I may be muddying the waters by posting my issues with lovesnapped
I will continue this discussion on another thread that I actually started.

@Rick so I was able to put the spring back but i am unsure what is happening now. So when I go to the move tab and move the table up, it actually goes down, and when I move it down it goes up. Any ideas?

In Edit > Device Settings is a button to ‘Negate Z’ - Click that and see if that helps. (I’m actually not certain if it changes the jog directions without looking at the code, but it’s a quick thing to try)

Never mind I found it :woman_facepalming:t4:. Now for some reason I set my start from to absolute coords. When I hit frame,it goes to a different place on the bed. How can I fix that? It wasnt doing that before

Did you follow these instructions?