Anyone else have issues with the 1.4.04 release

I create art in Illustrator export as DXF then import into lightburn. All good until the latest update. Now the imported art is disformed, even simple things like text, heart, star graphics, all messed up. Reverted back and problem solved.

Lightburn imports .ai files perfectly for me. Did you try that format instead of dxf?

ai import does not work well for what I do, maybe with some fiddling it will, but dxf worked perfectly. Hopefully this will get addressed soon.

I am having issues with designs that i have created in Lightburn and not framing. it is framing like 10x the size that the design calls for and the Motion of the Laser is like warp speed compared to what it was in the previous version, anyone else having similar issues?

following this what I have found is that the Y axis which is set to MM appears to be moving 1mm = 10mm of movement so If I want to move the Laser to x20 Y20, I need to enter X20 Y2 for it to meet the required coordinates. this is why nothing is framing as it should be. seems like a software defect to me

Or, more likely, a configuration change.

If you were using millimeters and LightBurn is now set to inches, that’s a quick factor of 25.4 more in both size and speed.

Check Edit → Settings → Display & Units to make sure they are with what you expect.

If i didnt know any better i would ask you to check if your rotary is enabled for some strange reason.

The Y stepper motor being this different makes me think Rotary

Yes but not with that issue. Since the .04 release was installed I could not get LB and my laser to talk. Come back as busy. Know several others in the Polar forum on FB had same and few other issues. Downgraded to 03 and laser n computer talk fine now.

Potential solution being tested here:

Top of thread:

If willing, you can follow that to try our latest, or you can always roll back to an older version (← click this) at any time. :slight_smile:

Back Story

Please don’t double post. It uses up resources and is not required. Thank you.

I suspect you’ve left the rotary on, as Gil suggests.

Having massive problems since 1.4.04. My Sculpfun S30 Pro no longer respects absolute coordinates - even though homing appears to still work ok. So much material wasted :frowning:

What do you mean by “no longer respects absolute coordinates”?

Does your machine home itself properly? After homing, if you click “Get Position” does it report zeros?

I have solved my issues and they had nothing to do with Lightburn.

The reason for my cutting issues originated from the Sculpfun engrave settings described in this official Sculpfun video: that deals with engrave speeds of up to 25,000 mm/min for a scan angle of 0 degree.

Among the machine settings that had to be changed for my Sculpfun S30 Pro were the X Acceleration and Y Acceleration settings. The original value was 1,000.00 mm/sec^2 for each and the modified setting was 2,500.00 mm/sec^2.

Obviously the modified settings were fine for high-speed engraving (at a scan angle of 0 degree), but they are too fast for cutting where the scan angle can be anything from 0 to 360 degree.

Once I modified those values back to their original value of 1,000.00 mm/sec^2 all of my cutting problems were gone. Lightburn again cuts every item at exactly the position it is supposed to. I have since upgraded Lightburn to the latest version again and it is working perfectly fine.

Bottom line: the fast engrave machine settings from the Sculpfun video linked aboev can be used only for engraving and at least the X and Y Acceleration machine settings have to be reverted to their original values for cutting.

I appreciate you updating the post and absolving the update. I see so many posts on Facebook where users blame the update for various things that were ultimately their own fault, and it causes a lot of others to be wary of updating.

Not to say we’re perfect, but I prefer only being blamed for the things I actually did. :slight_smile:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.