Arduino Based cheap laser engraver help please

Hi, Help please!
I have read through lots of posts and watched hours worth of videos but I am still stuck.
I have purchased a cheap (wanted but couldn’t afford a better one) laser engraver from Ebay.
It came with Benbox software which works on simple things, but keeps crashing mid engrave for anything detailed.
The laser is unbranded, has small arduino type board as the controller.
Its a 2500mw laser with x and y stepper motors.
The bed is 400 x 500 mm.
When running Benbox, it made you choose the controller which was:
I think it read grbl 1.1e on the output screen.
I want to buy some better software and Lightburn came highly recommended from Facebook, but I can’t get the trial to work.

I have tried each of the controllers, some will even start… but never turn the laser on (it moves like it is engraving), none will let me move the laser.

Any help to get started would be gratefully received.

OK, starting to get somewhere, I had to load the Benbox software onto this pc, maybe it contains some control software, then it let Lightburn control the laser. I still cant home or move the laser though, those controls do nothing. :frowning:

Lightburn connects directly to your laser without any intermediary software. You do not need Benbox installed to use Lightburn.

When you setup your machine in LB, you should select GRBL-M3 since it has the GRBL1.1e firmware.

hmmm I tried that first and nothing happened, I am assuming it had some other set up in the software?? still cant use any of the move , home functions though,

It is on that one now, that lets it engrave, but cant control where or move the laser using the ‘move’ window

Are you certain it’s running GRBL 1.1e? I have done a little digging and it looks like the Benbox software only works with a custom version of the firmware. I think you’ll need to upload a new GRBL firmware to your laser to use it with LB. You can find instructions to do that here.

Those instructions will let you install GRBL 1.1f on your laser. You’ll then need to change it in LB from GRBL-M3 to GRBL.

Can you post a picture of the control board? It will help others to help you.

Thank you for your time, I will try that,
just looking up how to run the Arduino IDE, not done that before.
this is the board.

Tried to upload GRBL using the arduino IDE but cant get it to compile let alone upload :frowning:
it adds the library ok, but cant get any further :frowning:

tried every board selection available, none will compile,
I found some simplistic board detection software that should bring back the board name, looks like Python. but this won’t compile because it cant find the board.:frowning:
so disheartening

I found this link
This was not good. He had to replace the arduino board completely as the board was an arduino copy and not compatible with the arduino IDE at all. It would seem I am having the same issue, so unless anyone knows of a way around this I’m stuck with Benbox :sob::sob::sob:

Download the GRBL 1.1f hex file from here:

Then use Xloader, available here:

to flash the hex file to the arduino board


OMG that was so easy and worked straight away!!!(well second board choice)
I can’t thank you all enough :grin::grin::grin:
I can use the move functions now and the laser seems responsive to home etc.
The X axis is the wrong way around, but I am sure I read how to swap that earlier so will look again in the morning.

Thanks again, :heart_eyes:


Glad I was able to help. Enjoy using LightBurn!

1 Like