Arrow key jogging

Hello there!
I’m setting up a k-40 with a mini gerbil board and I’m trying to figure out if there’s a way to jog with arrow keys or number pad or anything? Coming from Linux CNC control of my k40 and arrow keys are second nature to all CNCs that I’ve used. Is there any way to do this in light burn? I’ve tried the number pad with num lock on and off nothing jogs it. Is there a way to enable this? I’m running Linux Ubuntu just downloaded the newest software light burn. Thanks for any help!

on my old windows 7 machine I often use the arrow keys to adjust my items on the laser bed, I do not think that a special command is needed. In settings you can even adjust 3 keys for fine or rough tuning in connection with the arrow keys. But I’m not sure or can not remember it right now if I also jog with the laser head itself, but I think so.

Thanks for the reply. I’m using linux with the Grbl STM and arrow keys don’t do anything to jog the laser head. Maybe different versions do different things?

Use the number pad arrows, with NumLock enabled. They will jog the laser.

Thanks for the response
I’ve tried running the arrows on the number pad with num lock on and off with no luck. Does it have to be in a certain state or home with switches or something like that? I’m running a k-40 with Linux Ubuntu and a mini gerbil board with no limit switches hooked up

Check to see if you have $J jogging enabled in the device settings. That would likely be the default for the GRBL driver, but without limit switches it won’t likely work.

So I looked for a jog setting in device settings machine settings and global settings and couldn’t find any such field. So one thing that is interesting is that the number pad arrow keys will actually blip the jog control and the laser will move like 1/16 of an inch in any direction continuing to press that same arrow key will stop working beyond that. The the arrow buttons on the screen continue to jog it in small increments as many times as I press them but the number pad will only move it a 16-in in any direction no matter how many times I press the buttons or hold them down. On the screen it shows that it’s processing stream commands and says it’s busy for a second but nothing happens beyond the 16th inch of travel. Any ideas? On the screen I see starting stream completed in zero: 00 on the next line it shows idle MPOS: 0.0519 a bunch of zeros with decimals beyond that

Step 1, make sure this is on in Edit > Device Settings:


Step 2:turn this on in the Move window:


1 Like

Thank you. Those options showed up when I changed the GRBL type from STM to regular GRBL. However the keypad will only let me jog within a small square envelope from 0,0 to 10,10mm. I had to start over because it forgot my machine from last session.

Awesome Tech recommends using GRBL-STM. Is there a downside to running plain GRBL so I can have jog capabilities (assuming I can figure out why it won’t jog more than 10mm with the keypad?

Mini GRBL control board
Linux Ubuntu OS

Check to see if you have ‘move from machine zero’ checked:

If you do, that would likely be why it’s stuck to the origin. I’ll check the Gerbil profile - the different jogging options should be exposed there too, so it might just be an oversight, or perhaps we hadn’t had a chance to try it on that hardware to make sure it worked. If you’re saying it does work, I can ren-enable it for Gerbil for the next release.

Switching to GRBL shouldn’t affect much. It forces the baud rate, sets dwells (pauses) to milliseconds because Paul (Awesome-Tech) changed the implementation for some reason, and it supports automatic connection. Otherwise, they’re the same driver.

Thank you. I’ve tried clicking from machine zero on and off with no luck. I learned today that whatever value in the move distance field is where it stays when jogging with the number pad. If I uncheck continuous jogging and enter a move distance it will move it to zero and limit motion between zero and whatever number is in that field in x and y. Cheers

In the Console window, click ‘Show All’, then try a jogging move, and copy / paste the console output here so I can see it.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.